summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/unzip/unzip_6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/unzip/unzip_6.0.bb')
-rw-r--r--meta/recipes-extended/unzip/unzip_6.0.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-extended/unzip/unzip_6.0.bb b/meta/recipes-extended/unzip/unzip_6.0.bb
new file mode 100644
index 0000000000..e590f8186d
--- /dev/null
+++ b/meta/recipes-extended/unzip/unzip_6.0.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Utilities for extracting and viewing files in .zip archives"
2HOMEPAGE = "http://www.info-zip.org"
3SECTION = "console/utils"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=94caec5a51ef55ef711ee4e8b1c69e29"
6PE = "1"
7PR = "r5"
8
9SRC_URI = "ftp://ftp.info-zip.org/pub/infozip/src/unzip60.tgz \
10 file://avoid-strip.patch \
11 file://define-ldflags.patch \
12 file://06-unzip60-alt-iconv-utf8_CVE-2015-1315.patch \
13 file://unzip-6.0_overflow3.diff \
14 file://09-cve-2014-8139-crc-overflow.patch \
15 file://10-cve-2014-8140-test-compr-eb.patch \
16 file://11-cve-2014-8141-getzip64data.patch \
17"
18
19SRC_URI[md5sum] = "62b490407489521db863b523a7f86375"
20SRC_URI[sha256sum] = "036d96991646d0449ed0aa952e4fbe21b476ce994abc276e49d30e686708bd37"
21S = "${WORKDIR}/unzip60"
22
23# Makefile uses CF_NOOPT instead of CFLAGS. We lifted the values from
24# Makefile and add CFLAGS. Optimization will be overriden by unzip
25# configure to be -O3.
26#
27EXTRA_OEMAKE += "STRIP=true LF2='' \
28 'CF_NOOPT=-I. -Ibzip2 -DUNIX ${CFLAGS}'"
29
30export LD = "${CC}"
31LD_class-native = "${CC}"
32
33do_compile() {
34 oe_runmake -f unix/Makefile generic
35}
36
37do_install() {
38 oe_runmake -f unix/Makefile install prefix=${D}${prefix}
39 install -d ${D}${mandir}
40 mv ${D}${prefix}/man/* ${D}${mandir}
41 rmdir ${D}${prefix}/man/
42}
43
44BBCLASSEXTEND = "native"