summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzdata/tzdata_2015g.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tzdata/tzdata_2015g.bb')
-rw-r--r--meta/recipes-extended/tzdata/tzdata_2015g.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-extended/tzdata/tzdata_2015g.bb b/meta/recipes-extended/tzdata/tzdata_2015g.bb
index 5b2afa6a31..a6faa1d19c 100644
--- a/meta/recipes-extended/tzdata/tzdata_2015g.bb
+++ b/meta/recipes-extended/tzdata/tzdata_2015g.bb
@@ -21,6 +21,7 @@ RCONFLICTS_${PN} = "timezones timezone-africa timezone-america timezone-antarcti
21S = "${WORKDIR}" 21S = "${WORKDIR}"
22 22
23DEFAULT_TIMEZONE ?= "Universal" 23DEFAULT_TIMEZONE ?= "Universal"
24INSTALL_TIMEZONE_FILE ?= "1"
24 25
25TZONES= "africa antarctica asia australasia europe northamerica southamerica \ 26TZONES= "africa antarctica asia australasia europe northamerica southamerica \
26 factory etcetera backward systemv \ 27 factory etcetera backward systemv \
@@ -48,7 +49,9 @@ do_install () {
48 # Install default timezone 49 # Install default timezone
49 if [ -e ${D}${datadir}/zoneinfo/${DEFAULT_TIMEZONE} ]; then 50 if [ -e ${D}${datadir}/zoneinfo/${DEFAULT_TIMEZONE} ]; then
50 install -d ${D}${sysconfdir} 51 install -d ${D}${sysconfdir}
51 echo ${DEFAULT_TIMEZONE} > ${D}${sysconfdir}/timezone 52 if [ "${INSTALL_TIMEZONE_FILE}" == "1" ]; then
53 echo ${DEFAULT_TIMEZONE} > ${D}${sysconfdir}/timezone
54 fi
52 ln -s ${datadir}/zoneinfo/${DEFAULT_TIMEZONE} ${D}${sysconfdir}/localtime 55 ln -s ${datadir}/zoneinfo/${DEFAULT_TIMEZONE} ${D}${sysconfdir}/localtime
53 else 56 else
54 bberror "DEFAULT_TIMEZONE is set to an invalid value." 57 bberror "DEFAULT_TIMEZONE is set to an invalid value."
@@ -205,4 +208,5 @@ FILES_${PN} += "${datadir}/zoneinfo/Pacific/Honolulu \
205 ${datadir}/zoneinfo/iso3166.tab \ 208 ${datadir}/zoneinfo/iso3166.tab \
206 ${datadir}/zoneinfo/Etc/*" 209 ${datadir}/zoneinfo/Etc/*"
207 210
208CONFFILES_${PN} += "${sysconfdir}/timezone ${sysconfdir}/localtime" 211CONFFILES_${PN} += "${@ "${sysconfdir}/timezone" if bb.utils.to_boolean(d.getVar('INSTALL_TIMEZONE_FILE', True)) else "" }"
212CONFFILES_${PN} += "${sysconfdir}/localtime"