summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2018d.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2018d.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2018d.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2018d.bb b/meta/recipes-extended/tzcode/tzcode-native_2018d.bb
new file mode 100644
index 0000000000..7933a5df96
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2018d.bb
@@ -0,0 +1,30 @@
1# note that we allow for us to use data later than our code version
2#
3SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
4LICENSE = "PD & BSD & BSD-3-Clause"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=c679c9d6b02bc2757b3eaf8f53c43fba"
7
8SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
9 http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata \
10 "
11
12UPSTREAM_CHECK_URI = "http://www.iana.org/time-zones"
13
14SRC_URI[tzcode.md5sum] = "96612b4f5d7e8804fd9a0981c021be90"
15SRC_URI[tzcode.sha256sum] = "7de44e85baad748d217e3fd60706f599f9aec68bce6356b163f52b0dbd40a8d9"
16SRC_URI[tzdata.md5sum] = "871a7ef808eb42ebc551acdb3d661554"
17SRC_URI[tzdata.sha256sum] = "5106eddceb5f1ae3a91dbd3960e1b8b11ba0dc08579a31cf0724a7691b10c054"
18
19S = "${WORKDIR}"
20
21inherit native
22
23EXTRA_OEMAKE += "cc='${CC}'"
24
25do_install () {
26 install -d ${D}${bindir}/
27 install -m 755 zic ${D}${bindir}/
28 install -m 755 zdump ${D}${bindir}/
29 install -m 755 tzselect ${D}${bindir}/
30}