summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tzcode/tzcode-native_2016f.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tzcode/tzcode-native_2016f.bb')
-rw-r--r--meta/recipes-extended/tzcode/tzcode-native_2016f.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/tzcode/tzcode-native_2016f.bb b/meta/recipes-extended/tzcode/tzcode-native_2016f.bb
new file mode 100644
index 0000000000..a50a2845d9
--- /dev/null
+++ b/meta/recipes-extended/tzcode/tzcode-native_2016f.bb
@@ -0,0 +1,26 @@
1# note that we allow for us to use data later than our code version
2#
3SUMMARY = "tzcode, timezone zoneinfo utils -- zic, zdump, tzselect"
4LICENSE = "PD & BSD & BSD-3-Clause"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=76ae2becfcb9a685041c6f166b44c2c2"
7
8SRC_URI =" http://www.iana.org/time-zones/repository/releases/tzcode${PV}.tar.gz;name=tzcode \
9 http://www.iana.org/time-zones/repository/releases/tzdata${PV}.tar.gz;name=tzdata"
10
11SRC_URI[tzcode.md5sum] = "b93618bb84e38dee102e0e41ec9d13e2"
12SRC_URI[tzcode.sha256sum] = "72325f384490a310eeb2ea0fab7e6f011a5be19adab2ff9d83bf9d1993b066ed"
13
14SRC_URI[tzdata.md5sum] = "b20b3c1618db1984aac685e763de001d"
15SRC_URI[tzdata.sha256sum] = "ed8c951008d12f1db55a11e96fc055718c6571233327d9de16a7f8475e2502b0"
16
17S = "${WORKDIR}"
18
19inherit native
20
21do_install () {
22 install -d ${D}${bindir}/
23 install -m 755 zic ${D}${bindir}/
24 install -m 755 zdump ${D}${bindir}/
25 install -m 755 tzselect ${D}${bindir}/
26}