summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/texinfo/texinfo_5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/texinfo/texinfo_5.2.bb')
-rw-r--r--meta/recipes-extended/texinfo/texinfo_5.2.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/meta/recipes-extended/texinfo/texinfo_5.2.bb b/meta/recipes-extended/texinfo/texinfo_5.2.bb
new file mode 100644
index 0000000000..cf9dcfd5de
--- /dev/null
+++ b/meta/recipes-extended/texinfo/texinfo_5.2.bb
@@ -0,0 +1,77 @@
1SUMMARY = "Documentation system for on-line information and printed output"
2DESCRIPTION = "Texinfo is a documentation system that can produce both \
3online information and printed output from a single source file. The \
4GNU Project uses the Texinfo file format for most of its documentation."
5HOMEPAGE = "http://www.gnu.org/software/texinfo/"
6SECTION = "console/utils"
7LICENSE = "GPLv3+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9
10PROVIDES_append_class-native = " texinfo-replacement-native"
11
12def compress_pkg(d):
13 if "compress_doc" in (d.getVar("INHERIT", True) or "").split():
14 compress = d.getVar("DOC_COMPRESS", True)
15 if compress == "gz":
16 return "gzip"
17 elif compress == "bz2":
18 return "bzip2"
19 elif compress == "xz":
20 return "xz"
21 return ""
22
23RDEPENDS_info += "${@compress_pkg(d)}"
24
25DEPENDS = "zlib ncurses texinfo-replacement-native"
26DEPENDS_class-native = "zlib-native ncurses-native"
27
28TARGET_PATCH = "file://use_host_makedoc.patch"
29TARGET_PATCH_class-native = ""
30
31SRC_URI = "${GNU_MIRROR}/texinfo/${BP}.tar.gz \
32 file://texinfo-4.12-zlib.patch \
33 file://texinfo-4.13a-powerpc.patch \
34 file://disable-native-tools.patch \
35 file://link-zip.patch \
36 file://dont-depend-on-help2man.patch \
37 ${TARGET_PATCH} \
38 "
39
40SRC_URI[md5sum] = "1b8f98b80a8e6c50422125e07522e8db"
41SRC_URI[sha256sum] = "6b8ca30e9b6f093b54fe04439e5545e564c63698a806a48065c0bba16994cf74"
42
43S = "${WORKDIR}/${BP}"
44tex_texinfo = "texmf/tex/texinfo"
45
46inherit gettext autotools
47
48do_compile_prepend() {
49 if [ -d tools ];then
50 oe_runmake -C tools/gnulib/lib
51 fi
52}
53
54do_install_append() {
55 mkdir -p ${D}${datadir}/${tex_texinfo}
56 install -p -m644 ${S}/doc/texinfo.tex ${S}/doc/txi-??.tex ${D}${datadir}/${tex_texinfo}
57 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/texi2any ${D}${bindir}/pod2texi
58}
59
60do_install_append_class-native() {
61 install -m 755 info/makedoc ${D}${bindir}
62}
63
64PACKAGES += "info info-doc"
65
66FILES_info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info"
67FILES_info-doc = "${infodir}/info.info* ${infodir}/dir ${infodir}/info-*.info* \
68 ${mandir}/man1/info.1* ${mandir}/man5/info.5* \
69 ${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*"
70
71FILES_${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi ${bindir}/pod2texi ${datadir}/texinfo"
72RDEPENDS_${PN} = "perl"
73FILES_${PN}-doc = "${infodir}/texinfo* \
74 ${datadir}/${tex_texinfo} \
75 ${mandir}/man1 ${mandir}/man5"
76
77BBCLASSEXTEND = "native"