summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/texinfo/texinfo_4.13a.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/texinfo/texinfo_4.13a.bb')
-rw-r--r--meta/recipes-extended/texinfo/texinfo_4.13a.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-extended/texinfo/texinfo_4.13a.bb b/meta/recipes-extended/texinfo/texinfo_4.13a.bb
new file mode 100644
index 0000000000..be10c26a0b
--- /dev/null
+++ b/meta/recipes-extended/texinfo/texinfo_4.13a.bb
@@ -0,0 +1,57 @@
1DESCRIPTION = "Texinfo is a documentation system that can produce both online \
2information and printed output from a single source file. The GNU \
3Project uses the Texinfo file format for most of its documentation."
4
5SECTION = "console/utils"
6HOMEPAGE = "http://www.gnu.org/software/texinfo/"
7PRIORITY = "required"
8LICENSE = "GPLV3+"
9PR = "r0"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=adefda309052235aa5d1e99ce7557010"
12
13DEPENDS = "zlib"
14
15SRC_URI = "http://ftp.gnu.org/gnu/texinfo/texinfo-${PV}.tar.gz \
16 file://texinfo-4.12-zlib.patch;striplevel=1 \
17 file://texinfo-4.13a-data_types.patch;striplevel=1 \
18 file://texinfo-4.13a-mosdo-crash.patch;striplevel=1 \
19 file://texinfo-4.13a-powerpc.patch;striplevel=1 \
20 file://texinfo-4.13a-help-index-segfault.patch;striplevel=1"
21
22inherit gettext autotools
23
24S = ${WORKDIR}/texinfo-4.13
25tex_texinfo = "texmf/tex/texinfo"
26
27do_configure() {
28 oe_runconf
29}
30
31do_compile_prepend(){
32 if [ -d tools ];then
33 make -C tools/gnulib/lib
34 fi
35}
36
37do_install_append() {
38 mkdir -p ${D}${datadir}/${tex_texinfo}
39 install -p -m644 doc/texinfo.tex doc/txi-??.tex ${D}${datadir}/${tex_texinfo}
40}
41
42PACKAGES += "info info-doc info-dbg"
43
44FILES_info = "${bindir}/info ${bindir}/infokey ${bindir}/install-info"
45FILES_info-doc = "${infodir}/info.info ${infodir}/dir ${infodir}/info-*.info \
46 ${mandir}/man1/info.1* ${mandir}/man5/info.5* \
47 ${mandir}/man1/infokey.1* ${mandir}/man1/install-info.1*"
48FILES_info-dbg = "${bindir}/.debug/info ${bindir}/.debug/install-info \
49 ${bindir}/.debug/infokey"
50
51FILES_${PN} = "${bindir}/makeinfo ${bindir}/texi* ${bindir}/pdftexi2dvi"
52FILES_${PN}-doc = "${datadir}/texinfo ${infodir}/texinfo* \
53 ${datadir}/${tex_texinfo} \
54 ${mandir}/man1/makeinfo.1* ${mandir}/man5/texinfo.5* \
55 ${mandir}/man1/texindex.1* ${mandir}/man1/texi2dvi.1* \
56 ${mandir}/man1/texi2pdf.1* ${mandir}/man1/pdftexi2dvi.1*"
57FILES_${PN}-dbg = "${bindir}/.debug/texindex ${bindir}/.debug/makeinfo"