summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb')
-rw-r--r--meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb128
1 files changed, 128 insertions, 0 deletions
diff --git a/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb b/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb
new file mode 100644
index 0000000000..4d6430634e
--- /dev/null
+++ b/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb
@@ -0,0 +1,128 @@
1SUMMARY = "Security tool that is a wrapper for TCP daemons"
2DESCRIPTION = "Tools for monitoring and filtering incoming requests for tcp \
3 services."
4SECTION = "console/network"
5
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://DISCLAIMER;md5=071bd69cb78b18888ea5e3da5c3127fa"
8PR ="r10"
9
10
11PACKAGES = "${PN}-dbg libwrap libwrap-doc libwrap-dev libwrap-staticdev ${PN} ${PN}-doc"
12FILES_libwrap = "${base_libdir}/lib*${SOLIBS}"
13FILES_libwrap-doc = "${mandir}/man3 ${mandir}/man5"
14FILES_libwrap-dev = "${libdir}/lib*${SOLIBSDEV} ${includedir}"
15FILES_libwrap-staticdev = "${libdir}/lib*.a"
16FILES_${PN} = "${sbindir}"
17FILES_${PN}-doc = "${mandir}/man8"
18
19SRC_URI = "ftp://ftp.porcupine.org/pub/security/tcp_wrappers_${PV}.tar.gz \
20 file://00_man_quoting.diff \
21 file://01_man_portability.patch \
22 file://05_wildcard_matching.patch \
23 file://06_fix_gethostbyname.patch \
24 file://10_usagi-ipv6.patch \
25 file://11_tcpd_blacklist.patch \
26 file://11_usagi_fix.patch \
27 file://12_makefile_config.patch \
28 file://13_shlib_weaksym.patch \
29 file://14_cidr_support.patch \
30 file://15_match_clarify.patch \
31 file://expand_remote_port.patch \
32 file://have_strerror.patch \
33 file://man_fromhost.patch \
34 file://restore_sigalarm.patch \
35 file://rfc931.diff \
36 file://safe_finger.patch \
37 file://sig_fix.patch \
38 file://siglongjmp.patch \
39 file://socklen_t.patch \
40 file://tcpdchk_libwrapped.patch \
41 file://ldflags.patch \
42 file://rename_strings_variable.patch \
43 \
44 file://try-from.8 \
45 file://safe_finger.8"
46
47SRC_URI[md5sum] = "e6fa25f71226d090f34de3f6b122fb5a"
48SRC_URI[sha256sum] = "9543d7adedf78a6de0b221ccbbd1952e08b5138717f4ade814039bb489a4315d"
49
50S = "${WORKDIR}/tcp_wrappers_${PV}"
51
52PARALLEL_MAKE = ""
53EXTRA_OEMAKE = "'CC=${CC}' \
54 'AR=${AR}' \
55 'RANLIB=${RANLIB}' \
56 'REAL_DAEMON_DIR=${sbindir}' \
57 'STYLE=-DPROCESS_OPTIONS' \
58 'FACILITY=LOG_DAEMON' \
59 'SEVERITY=LOG_INFO' \
60 'BUGS=' \
61 'VSYSLOG=' \
62 'RFC931_TIMEOUT=10' \
63 'ACCESS=-DHOSTS_ACCESS' \
64 'KILL_OPT=-DKILL_IP_OPTIONS' \
65 'UMASK=-DDAEMON_UMASK=022' \
66 'NETGROUP=${EXTRA_OEMAKE_NETGROUP}' \
67 'LIBS=-lnsl' \
68 'ARFLAGS=rv' \
69 'AUX_OBJ=weak_symbols.o' \
70 'TLI=' \
71 'COPTS=' \
72 'EXTRA_CFLAGS=${CFLAGS} -DSYS_ERRLIST_DEFINED -DHAVE_STRERROR -DHAVE_WEAKSYMS -D_REENTRANT -DINET6=1 -Dss_family=__ss_family -Dss_len=__ss_len'"
73
74EXTRA_OEMAKE_NETGROUP = "-DNETGROUP -DUSE_GETDOMAIN"
75EXTRA_OEMAKE_NETGROUP_libc-uclibc = "-DUSE_GETDOMAIN"
76
77do_compile () {
78 oe_runmake 'TABLES=-DHOSTS_DENY=\"${sysconfdir}/hosts.deny\" -DHOSTS_ALLOW=\"${sysconfdir}/hosts.allow\"' \
79 all
80}
81
82BINS = "safe_finger tcpd tcpdchk try-from tcpdmatch"
83MANS3 = "hosts_access"
84MANS5 = "hosts_options"
85MANS8 = "tcpd tcpdchk tcpdmatch"
86do_install () {
87 oe_libinstall -a libwrap ${D}${libdir}
88 oe_libinstall -C shared -so libwrap ${D}${base_libdir}
89
90 if [ "${libdir}" != "${base_libdir}" ] ; then
91 rel_lib_prefix=`echo ${libdir} | sed 's,\(^/\|\)[^/][^/]*,..,g'`
92 libname=`readlink ${D}${base_libdir}/libwrap.so | xargs basename`
93 ln -s ${rel_lib_prefix}${base_libdir}/${libname} ${D}${libdir}/libwrap.so
94 rm -f ${D}${base_libdir}/libwrap.so
95 fi
96
97 install -d ${D}${sbindir}
98 for b in ${BINS}; do
99 install -m 0755 $b ${D}${sbindir}/ || exit 1
100 done
101
102 install -d ${D}${mandir}/man3
103 for m in ${MANS3}; do
104 install -m 0644 $m.3 ${D}${mandir}/man3/ || exit 1
105 done
106
107 install -d ${D}${mandir}/man5
108 for m in ${MANS5}; do
109 install -m 0644 $m.5 ${D}${mandir}/man5/ || exit 1
110 done
111
112 install -d ${D}${mandir}/man8
113 for m in ${MANS8}; do
114 install -m 0644 $m.8 ${D}${mandir}/man8/ || exit 1
115 done
116
117 install -m 0644 ${WORKDIR}/try-from.8 ${D}${mandir}/man8/
118 install -m 0644 ${WORKDIR}/safe_finger.8 ${D}${mandir}/man8/
119
120 install -d ${D}${includedir}
121 install -m 0644 tcpd.h ${D}${includedir}/
122
123 install -d ${D}${sysconfdir}
124 touch ${D}${sysconfdir}/hosts.allow
125 touch ${D}${sysconfdir}/hosts.deny
126}
127
128FILES_${PN} += "${sysconfdir}/hosts.allow ${sysconfdir}/hosts.deny"