summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb')
-rw-r--r--meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb117
1 files changed, 117 insertions, 0 deletions
diff --git a/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb b/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb
new file mode 100644
index 0000000000..308a8b63b4
--- /dev/null
+++ b/meta/recipes-extended/tcp-wrappers/tcp-wrappers_7.6.bb
@@ -0,0 +1,117 @@
1DESCRIPTION = "Tools for monitoring and filtering incoming requests for tcp \
2 services."
3PRIORITY = "optional"
4SECTION = "console/network"
5
6LICENSE = "tcp-wrappers"
7LIC_FILES_CHKSUM = "file://DISCLAIMER;md5=071bd69cb78b18888ea5e3da5c3127fa"
8PR ="r0"
9
10
11PACKAGES = "${PN}-dbg libwrap libwrap-doc libwrap-dev tcp-wrappers tcp-wrappers-doc"
12FILES_libwrap = "${base_libdir}/lib*.so.*"
13FILES_libwrap-doc = "${mandir}/man3 ${mandir}/man5"
14FILES_libwrap-dev = "${libdir}/lib*.so ${libdir}/lib*.a ${includedir}"
15FILES_tcp-wrappers = "${bindir}"
16FILES_tcp-wrappers-doc = "${mandir}/man8"
17
18SRC_URI = "ftp://ftp.porcupine.org/pub/security/tcp_wrappers_${PV}.tar.gz \
19 file://00_man_quoting.diff \
20 file://01_man_portability.patch \
21 file://05_wildcard_matching.patch \
22 file://06_fix_gethostbyname.patch \
23 file://10_usagi-ipv6.patch \
24 file://11_tcpd_blacklist.patch \
25 file://11_usagi_fix.patch \
26 file://12_makefile_config.patch \
27 file://13_shlib_weaksym.patch \
28 file://14_cidr_support.patch \
29 file://15_match_clarify.patch \
30 file://expand_remote_port.patch \
31 file://have_strerror.patch \
32 file://man_fromhost.patch \
33 file://restore_sigalarm.patch \
34 file://rfc931.diff \
35 file://safe_finger.patch \
36 file://sig_fix.patch \
37 file://siglongjmp.patch \
38 file://size_t.patch \
39 file://tcpdchk_libwrapped.patch \
40 file://ldflags.patch \
41 \
42 file://try-from.8 \
43 file://safe_finger.8"
44
45S = "${WORKDIR}/tcp_wrappers_${PV}"
46
47PARALLEL_MAKE = ""
48EXTRA_OEMAKE = "'CC=${CC}' \
49 'AR=${AR}' \
50 'RANLIB=${RANLIB}' \
51 'REAL_DAEMON_DIR=${sbindir}' \
52 'STYLE=-DPROCESS_OPTIONS' \
53 'FACILITY=LOG_DAEMON' \
54 'SEVERITY=LOG_INFO' \
55 'BUGS=' \
56 'VSYSLOG=' \
57 'RFC931_TIMEOUT=10' \
58 'ACCESS=-DHOSTS_ACCESS' \
59 'KILL_OPT=-DKILL_IP_OPTIONS' \
60 'UMASK=-DDAEMON_UMASK=022' \
61 'NETGROUP=${EXTRA_OEMAKE_NETGROUP}' \
62 'LIBS=-lnsl' \
63 'ARFLAGS=rv' \
64 'AUX_OBJ=weak_symbols.o' \
65 'TLI=' \
66 'COPTS=' \
67 'EXTRA_CFLAGS=${CFLAGS} -DSYS_ERRLIST_DEFINED -DHAVE_STRERROR -DHAVE_WEAKSYMS -D_REENTRANT -DINET6=1 -Dss_family=__ss_family -Dss_len=__ss_len'"
68
69EXTRA_OEMAKE_NETGROUP = "-DNETGROUP -DUSE_GETDOMAIN"
70EXTRA_OEMAKE_NETGROUP_linux-uclibc = "-DUSE_GETDOMAIN"
71EXTRA_OEMAKE_NETGROUP_linux-uclibceabi = "-DUSE_GETDOMAIN"
72
73do_compile () {
74 oe_runmake 'TABLES=-DHOSTS_DENY=\"${sysconfdir}/hosts.deny\" -DHOSTS_ALLOW=\"${sysconfdir}/hosts.allow\"' \
75 all
76}
77
78BINS = "safe_finger tcpd tcpdchk try-from tcpdmatch"
79MANS3 = "hosts_access"
80MANS5 = "hosts_options"
81MANS8 = "tcpd tcpdchk tcpdmatch"
82do_install () {
83 oe_libinstall -a libwrap ${D}${libdir}
84 oe_libinstall -C shared -so libwrap ${D}${base_libdir}
85
86 rel_lib_prefix=`echo ${libdir} | sed 's,\(^/\|\)[^/][^/]*,..,g'`
87 libname=`readlink ${D}${base_libdir}/libwrap.so | xargs basename`
88 ln -s ${rel_lib_prefix}${base_libdir}/${libname} ${D}${libdir}/libwrap.so
89 rm -f ${D}${base_libdir}/libwrap.so
90
91 install -d ${D}${sbindir}
92 for b in ${BINS}; do
93 install -m 0755 $b ${D}${sbindir}/ || exit 1
94 done
95
96 install -d ${D}${mandir}/man3
97 for m in ${MANS3}; do
98 install -m 0644 $m.3 ${D}${mandir}/man3/ || exit 1
99 done
100
101 install -d ${D}${mandir}/man5
102 for m in ${MANS5}; do
103 install -m 0644 $m.5 ${D}${mandir}/man5/ || exit 1
104 done
105
106 install -d ${D}${mandir}/man8
107 for m in ${MANS8}; do
108 install -m 0644 $m.8 ${D}${mandir}/man8/ || exit 1
109 done
110
111 install -m 0644 ${WORKDIR}/try-from.8 ${D}${mandir}/man8/
112 install -m 0644 ${WORKDIR}/safe_finger.8 ${D}${mandir}/man8/
113
114 install -d ${D}${includedir}
115 install -m 0644 tcpd.h ${D}${includedir}/
116}
117