summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tasks/task-poky-lsb.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tasks/task-poky-lsb.bb')
-rw-r--r--meta/recipes-extended/tasks/task-poky-lsb.bb103
1 files changed, 103 insertions, 0 deletions
diff --git a/meta/recipes-extended/tasks/task-poky-lsb.bb b/meta/recipes-extended/tasks/task-poky-lsb.bb
new file mode 100644
index 0000000000..4718f3b760
--- /dev/null
+++ b/meta/recipes-extended/tasks/task-poky-lsb.bb
@@ -0,0 +1,103 @@
1#
2# Copyright (C) 2010 Intel Corporation
3#
4
5DESCRIPTION = "Create Small Image Tasks"
6PR = "r1"
7
8PACKAGES = "\
9 task-poky-lsb \
10 task-poky-sys-extended \
11 task-poky-sys-extended-dbg \
12 task-poky-sys-extended-dev \
13 task-poky-db \
14 task-poky-db-dbg \
15 task-poky-db-dev \
16 task-poky-misc \
17 task-poky-misc-dbg \
18 task-poky-misc-dev \
19 task-poky-perl \
20 task-poky-perl-dbg \
21 task-poky-perl-dev \
22 task-poky-python \
23 task-poky-python-dbg \
24 task-poky-python-dev \
25 task-poky-tcl \
26 task-poky-tcl-dbg \
27 task-poky-tcl-dev \
28 "
29
30ALLOW_EMPTY = "1"
31
32RDEPENDS_task-poky-lsb = "\
33 task-poky-sys-extended \
34 task-poky-db \
35 task-poky-misc \
36 task-poky-perl \
37 task-poky-python \
38 task-poky-tcl \
39 "
40
41#
42# GPLv2 Should List
43RDEPENDS_task-poky-sys-extended = "\
44 curl \
45 diffutils \
46 gamin \
47 hdparm \
48# libaio \
49 libxml2 \
50 lrzsz \
51 lzo \
52# mdadm \
53 minicom \
54 neon \
55 parted \
56 pth \
57 quota \
58# screen \
59 setserial \
60 sysstat \
61 unzip \
62# watchdog \
63 which \
64 zip \
65 "
66
67RDEPENDS_task-poky-db = "\
68 db \
69 sqlite3 \
70 "
71
72RDEPENDS_task-poky-perl = "\
73 gdbm \
74 perl \
75 zlib \
76 "
77
78
79RDEPENDS_task-poky-python = "\
80 expat \
81 gdbm \
82 gmp \
83 ncurses \
84 openssl \
85 python \
86 readline \
87 zip \
88 "
89
90RDEPENDS_task-poky-tcl = "\
91 tcl \
92 "
93
94RDEPENDS_task-poky-misc = "\
95 elfutils \
96 gettext \
97 lsof \
98 ncurses \
99 strace \
100 libusb1 \
101 usbutils \
102 zlib \
103 "