summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/tasks/task-core-lsb.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/tasks/task-core-lsb.bb')
-rw-r--r--meta/recipes-extended/tasks/task-core-lsb.bb198
1 files changed, 198 insertions, 0 deletions
diff --git a/meta/recipes-extended/tasks/task-core-lsb.bb b/meta/recipes-extended/tasks/task-core-lsb.bb
new file mode 100644
index 0000000000..ef8acb1359
--- /dev/null
+++ b/meta/recipes-extended/tasks/task-core-lsb.bb
@@ -0,0 +1,198 @@
1#
2# Copyright (C) 2010 Intel Corporation
3#
4
5DESCRIPTION = "Create Small Image Tasks"
6PR = "r3"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
9 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
10
11PACKAGES = "\
12 task-core-lsb \
13 task-core-sys-extended \
14 task-core-sys-extended-dbg \
15 task-core-sys-extended-dev \
16 task-core-db \
17 task-core-db-dbg \
18 task-core-db-dev \
19 task-core-misc \
20 task-core-misc-dbg \
21 task-core-misc-dev \
22 task-core-perl \
23 task-core-perl-dbg \
24 task-core-perl-dev \
25 task-core-python \
26 task-core-python-dbg \
27 task-core-python-dev \
28 task-core-tcl \
29 task-core-tcl-dbg \
30 task-core-tcl-dev \
31 task-core-lsb-perl-add \
32 task-core-lsb-python-add \
33 task-core-lsb-graphic-add \
34 task-core-lsb-runtime-add \
35 task-core-lsb-command-add \
36 "
37
38
39ALLOW_EMPTY = "1"
40
41RDEPENDS_task-core-lsb = "\
42 task-core-sys-extended \
43 task-core-db \
44 task-core-misc \
45 task-core-perl \
46 task-core-python \
47 task-core-tcl \
48 task-core-lsb-perl-add \
49 task-core-lsb-python-add \
50 task-core-lsb-graphic-add \
51 task-core-lsb-runtime-add \
52 task-core-lsb-command-add \
53 "
54
55RDEPENDS_task-core-sys-extended = "\
56 binutils \
57 chkconfig \
58 curl \
59 dhcp-client \
60 diffutils \
61 gamin \
62 hdparm \
63 libaio \
64 libxml2 \
65 lrzsz \
66 lzo \
67 mc \
68 mdadm \
69 minicom \
70 neon \
71 parted \
72 pth \
73 quota \
74 screen \
75 setserial \
76 sysstat \
77 unzip \
78 watchdog \
79 which \
80 xinetd \
81 zip \
82 "
83
84RDEPENDS_task-core-db = "\
85 db \
86 sqlite3 \
87 "
88
89RDEPENDS_task-core-perl = "\
90 gdbm \
91 perl \
92 zlib \
93 "
94
95
96RDEPENDS_task-core-python = "\
97 expat \
98 gdbm \
99 gmp \
100 ncurses \
101 openssl \
102 python \
103 readline \
104 zip \
105 "
106
107RDEPENDS_task-core-tcl = "\
108 tcl \
109 "
110
111RDEPENDS_task-core-misc = "\
112 elfutils \
113 gettext \
114 groff \
115 lsb \
116 lsbsetup \
117 lsof \
118 man \
119 man-pages \
120 ncurses \
121 strace \
122 libusb1 \
123 usbutils \
124 zlib \
125 "
126
127RDEPENDS_task-core-lsb-command-add = "\
128 localedef \
129 fontconfig-utils \
130 mailx \
131 msmtp \
132 chkconfig \
133"
134# cups
135
136RDEPENDS_task-core-lsb-perl-add = "\
137 perl-modules \
138 perl-dev \
139 perl-misc \
140 perl-pod \
141"
142
143RDEPENDS_task-core-lsb-python-add = "\
144 python-modules \
145 python-misc \
146"
147
148RDEPENDS_task-core-lsb-graphic-add = "\
149 libqtcore4 \
150 libqtgui4 \
151 libqtsql4 \
152 libqtsvg4 \
153 libqtxml4 \
154 libqtnetwork4 \
155 libxt \
156 libxxf86vm \
157 libdrm \
158 libglu \
159 libxi \
160 libxtst \
161 qt4-plugin-sqldriver-sqlite \
162 libx11-locale \
163 xorg-minimal-fonts \
164 gdk-pixbuf-loader-ico \
165 gdk-pixbuf-loader-bmp \
166 gdk-pixbuf-loader-ani \
167"
168
169RDEPENDS_task-core-lsb-graphic-add_qemux86 = "\
170 libqtopengl4 \
171"
172RDEPENDS_task-core-lsb-graphic-add_atom-pc = "\
173 libqtopengl4 \
174"
175RDEPENDS_task-core-lsb-graphic-add_qemuppc = "\
176 libqtopengl4 \
177"
178
179# mesa-dri
180
181RDEPENDS_task-core-lsb-runtime-add = "\
182 ldd \
183 pam-plugin-wheel \
184 e2fsprogs-mke2fs \
185 mkfontdir \
186 liburi-perl \
187 libxml-parser-perl \
188 libxml-perl \
189 eglibc-localedatas \
190 eglibc-gconvs \
191 eglibc-charmaps \
192 eglibc-binaries \
193 eglibc-localedata-posix \
194 eglibc-extra-nss \
195 eglibc-pcprofile \
196 eglibc-pic \
197 eglibc-utils \
198"