diff options
Diffstat (limited to 'meta/recipes-extended/tar/tar_1.33.bb')
-rw-r--r-- | meta/recipes-extended/tar/tar_1.33.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-extended/tar/tar_1.33.bb b/meta/recipes-extended/tar/tar_1.33.bb new file mode 100644 index 0000000000..5e34cdf9e5 --- /dev/null +++ b/meta/recipes-extended/tar/tar_1.33.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | SUMMARY = "GNU file archiving program" | ||
2 | DESCRIPTION = "GNU tar saves many files together into a single tape \ | ||
3 | or disk archive, and can restore individual files from the archive." | ||
4 | HOMEPAGE = "http://www.gnu.org/software/tar/" | ||
5 | SECTION = "base" | ||
6 | LICENSE = "GPLv3" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
8 | |||
9 | SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2" | ||
10 | |||
11 | SRC_URI[sha256sum] = "85b6953f4bc9666eb7db61b48f150dca21b941d85090171ea8c4f89902e460af" | ||
12 | |||
13 | inherit autotools gettext texinfo | ||
14 | |||
15 | PACKAGECONFIG ??= "" | ||
16 | PACKAGECONFIG_append_class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}" | ||
17 | |||
18 | PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl" | ||
19 | |||
20 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}" | ||
21 | |||
22 | CACHED_CONFIGUREVARS += "tar_cv_path_RSH=no" | ||
23 | |||
24 | # Let aclocal use the relative path for the m4 file rather than the | ||
25 | # absolute since tar has a lot of m4 files, otherwise there might | ||
26 | # be an "Argument list too long" error when it is built in a long/deep | ||
27 | # directory. | ||
28 | acpaths = "-I ./m4" | ||
29 | |||
30 | do_install () { | ||
31 | autotools_do_install | ||
32 | ln -s tar ${D}${bindir}/gtar | ||
33 | } | ||
34 | |||
35 | do_install_append_class-target() { | ||
36 | if [ "${base_bindir}" != "${bindir}" ]; then | ||
37 | install -d ${D}${base_bindir} | ||
38 | mv ${D}${bindir}/tar ${D}${base_bindir}/tar | ||
39 | mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar | ||
40 | rmdir ${D}${bindir}/ | ||
41 | fi | ||
42 | } | ||
43 | |||
44 | PACKAGES =+ "${PN}-rmt" | ||
45 | |||
46 | FILES_${PN}-rmt = "${sbindir}/rmt*" | ||
47 | |||
48 | inherit update-alternatives | ||
49 | |||
50 | ALTERNATIVE_PRIORITY = "100" | ||
51 | |||
52 | ALTERNATIVE_${PN} = "tar" | ||
53 | ALTERNATIVE_${PN}-rmt = "rmt" | ||
54 | ALTERNATIVE_${PN}_class-nativesdk = "" | ||
55 | ALTERNATIVE_${PN}-rmt_class-nativesdk = "" | ||
56 | |||
57 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" | ||
58 | ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt" | ||
59 | |||
60 | PROVIDES_append_class-native = " tar-replacement-native" | ||
61 | NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}" | ||
62 | |||
63 | BBCLASSEXTEND = "native nativesdk" | ||