diff options
Diffstat (limited to 'meta/recipes-extended/tar/tar_1.32.bb')
-rw-r--r-- | meta/recipes-extended/tar/tar_1.32.bb | 65 |
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-extended/tar/tar_1.32.bb b/meta/recipes-extended/tar/tar_1.32.bb new file mode 100644 index 0000000000..d14aeb8061 --- /dev/null +++ b/meta/recipes-extended/tar/tar_1.32.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | SUMMARY = "GNU file archiving program" | ||
2 | DESCRIPTION = "GNU tar saves many files together into a single tape \ | ||
3 | or disk archive, and can restore individual files from the archive." | ||
4 | HOMEPAGE = "http://www.gnu.org/software/tar/" | ||
5 | SECTION = "base" | ||
6 | LICENSE = "GPLv3" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
8 | |||
9 | SRC_URI = "${GNU_MIRROR}/tar/tar-${PV}.tar.bz2 \ | ||
10 | file://remove-gets.patch \ | ||
11 | file://musl_dirent.patch \ | ||
12 | " | ||
13 | |||
14 | SRC_URI[md5sum] = "17917356fff5cb4bd3cd5a6c3e727b05" | ||
15 | SRC_URI[sha256sum] = "e4bb9e08e12e7fa9f11fef544efc85e59ba34538593d9ad38148c7ca2bfbb566" | ||
16 | |||
17 | inherit autotools gettext texinfo | ||
18 | |||
19 | PACKAGECONFIG ??= "" | ||
20 | PACKAGECONFIG_append_class-target = " ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)}" | ||
21 | |||
22 | PACKAGECONFIG[acl] = "--with-posix-acls,--without-posix-acls,acl" | ||
23 | |||
24 | EXTRA_OECONF += "DEFAULT_RMT_DIR=${base_sbindir}" | ||
25 | |||
26 | # Let aclocal use the relative path for the m4 file rather than the | ||
27 | # absolute since tar has a lot of m4 files, otherwise there might | ||
28 | # be an "Argument list too long" error when it is built in a long/deep | ||
29 | # directory. | ||
30 | acpaths = "-I ./m4" | ||
31 | |||
32 | do_install () { | ||
33 | autotools_do_install | ||
34 | ln -s tar ${D}${bindir}/gtar | ||
35 | } | ||
36 | |||
37 | do_install_append_class-target() { | ||
38 | if [ "${base_bindir}" != "${bindir}" ]; then | ||
39 | install -d ${D}${base_bindir} | ||
40 | mv ${D}${bindir}/tar ${D}${base_bindir}/tar | ||
41 | mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar | ||
42 | rmdir ${D}${bindir}/ | ||
43 | fi | ||
44 | } | ||
45 | |||
46 | PACKAGES =+ "${PN}-rmt" | ||
47 | |||
48 | FILES_${PN}-rmt = "${base_sbindir}/rmt*" | ||
49 | |||
50 | inherit update-alternatives | ||
51 | |||
52 | ALTERNATIVE_PRIORITY = "100" | ||
53 | |||
54 | ALTERNATIVE_${PN} = "tar" | ||
55 | ALTERNATIVE_${PN}-rmt = "rmt" | ||
56 | ALTERNATIVE_${PN}_class-nativesdk = "" | ||
57 | ALTERNATIVE_${PN}-rmt_class-nativesdk = "" | ||
58 | |||
59 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" | ||
60 | ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt" | ||
61 | |||
62 | PROVIDES_append_class-native = " tar-replacement-native" | ||
63 | NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}" | ||
64 | |||
65 | BBCLASSEXTEND = "native nativesdk" | ||