summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/stress-ng/stress-ng_0.13.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/stress-ng/stress-ng_0.13.10.bb')
-rw-r--r--meta/recipes-extended/stress-ng/stress-ng_0.13.10.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.13.10.bb b/meta/recipes-extended/stress-ng/stress-ng_0.13.10.bb
new file mode 100644
index 0000000000..700ee1595e
--- /dev/null
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.13.10.bb
@@ -0,0 +1,24 @@
1SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master"
9SRCREV = "b81116cb69a97aa671ab207a7f600aaacca091d1"
10S = "${WORKDIR}/git"
11
12DEPENDS = "coreutils-native"
13
14PROVIDES = "stress"
15RPROVIDES:${PN} = "stress"
16RREPLACES:${PN} = "stress"
17RCONFLICTS:${PN} = "stress"
18
19inherit bash-completion
20
21do_install() {
22 oe_runmake DESTDIR=${D} install
23 ln -s stress-ng ${D}${bindir}/stress
24}