summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb')
-rw-r--r--meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb b/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb
new file mode 100644
index 0000000000..ba93efc4c8
--- /dev/null
+++ b/meta/recipes-extended/stress-ng/stress-ng_0.11.12.bb
@@ -0,0 +1,24 @@
1SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \
10 "
11SRC_URI[sha256sum] = "0ccf437ca1876a3e8a55986c6481697045203a17f5994cb2f5096cd461d18031"
12
13DEPENDS = "coreutils-native"
14
15PROVIDES = "stress"
16RPROVIDES_${PN} = "stress"
17RREPLACES_${PN} = "stress"
18RCONFLICTS_${PN} = "stress"
19
20inherit bash-completion
21
22do_install() {
23 oe_runmake DESTDIR=${D} install
24}