summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/stat/stat_3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/stat/stat_3.3.bb')
-rw-r--r--meta/recipes-extended/stat/stat_3.3.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/stat/stat_3.3.bb b/meta/recipes-extended/stat/stat_3.3.bb
new file mode 100644
index 0000000000..6754fb8cbd
--- /dev/null
+++ b/meta/recipes-extended/stat/stat_3.3.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Command line file status display utility"
2DESCRIPTION = "Displays all information about a file that the stat() call provides and all information about a filesystem that statfs() provides."
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=39886b077fd072e876e5c4c16310b631 \
6 file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8SRC_URI = "ftp://metalab.unc.edu/pub/Linux/utils/file/stat-${PV}.tar.gz \
9 file://fix-error-return.patch"
10
11SRC_URI[md5sum] = "37e247e8e400ad9205f1b0500b728fd3"
12SRC_URI[sha256sum] = "7071f0384a423a938dd542c1f08547a02824f6359acd3ef3f944b2c4c2d1ee09"
13
14do_install() {
15 install -d ${D}${base_bindir} ${D}${mandir}/man1
16 install -m 755 stat ${D}${base_bindir}/stat.stat
17 install -m 644 stat.1 ${D}${mandir}/man1
18}
19
20inherit update-alternatives
21
22ALTERNATIVE_${PN} = "stat"
23ALTERNATIVE_PRIORITY[stat] = "200"
24ALTERNATIVE_LINK_NAME[stat] = "${base_bindir}/stat"
25ALTERNATIVE_TARGET[stat] = "${base_bindir}/stat.stat"
26
27BBCLASSEXTEND = "native"
28