summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/stat/stat_3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/stat/stat_3.3.bb')
-rw-r--r--meta/recipes-extended/stat/stat_3.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/stat/stat_3.3.bb b/meta/recipes-extended/stat/stat_3.3.bb
new file mode 100644
index 0000000000..0c387420d7
--- /dev/null
+++ b/meta/recipes-extended/stat/stat_3.3.bb
@@ -0,0 +1,26 @@
1SECTION = "console/utils"
2DESCRIPTION = "Display all information about a file that the stat() call provides and all information a filesystem that statfs() provides."
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=39886b077fd072e876e5c4c16310b631 \
5 file://GPL;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7BBCLASSEXTEND = "native"
8
9PR = "r0"
10
11SRC_URI = "ftp://metalab.unc.edu/pub/Linux/utils/file/stat-3.3.tar.gz"
12SRC_URI[md5sum] = "37e247e8e400ad9205f1b0500b728fd3"
13SRC_URI[sha256sum] = "7071f0384a423a938dd542c1f08547a02824f6359acd3ef3f944b2c4c2d1ee09"
14
15do_install() {
16 install -d ${D}${bindir} ${D}${mandir}/man1
17 install -m 755 stat ${D}${bindir}
18 install -m 644 stat.1 ${D}${mandir}/man1
19}
20
21#do_install_virtclass-native() {
22# install -d ${D}${bindir}
23# install -m 755 stat ${D}${bindir}
24#}
25
26NATIVE_INSTALL_WORKS = "1"