diff options
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.3.1.bb')
-rw-r--r-- | meta/recipes-extended/slang/slang_2.3.1.bb | 58 |
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-extended/slang/slang_2.3.1.bb b/meta/recipes-extended/slang/slang_2.3.1.bb new file mode 100644 index 0000000000..7bf3af6836 --- /dev/null +++ b/meta/recipes-extended/slang/slang_2.3.1.bb | |||
@@ -0,0 +1,58 @@ | |||
1 | SUMMARY = "The shared library for the S-Lang extension language" | ||
2 | |||
3 | DESCRIPTION = "S-Lang is an interpreted language and a programming library. The \ | ||
4 | S-Lang language was designed so that it can be easily embedded into \ | ||
5 | a program to provide the program with a powerful extension language. \ | ||
6 | The S-Lang library, provided in this package, provides the S-Lang \ | ||
7 | extension language. S-Lang's syntax resembles C, which makes it easy \ | ||
8 | to recode S-Lang procedures in C if you need to." | ||
9 | |||
10 | HOMEPAGE = "http://www.jedsoft.org/slang/" | ||
11 | SECTION = "libs" | ||
12 | DEPENDS = "ncurses virtual/libiconv" | ||
13 | |||
14 | LICENSE = "GPLv2" | ||
15 | LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02" | ||
16 | |||
17 | |||
18 | SRC_URI = "http://www.jedsoft.org/releases/${BPN}/${BP}.tar.bz2 \ | ||
19 | file://rpathfix.patch \ | ||
20 | file://fix-check-pcre.patch \ | ||
21 | file://slang-fix-the-iconv-existence-checking.patch \ | ||
22 | file://no-x.patch \ | ||
23 | " | ||
24 | |||
25 | SRC_URI[md5sum] = "bd46d1dc17a50c72004ad842829d7b1f" | ||
26 | SRC_URI[sha256sum] = "a810d5da7b0c0c8c335393c6b4f12884be6fa7696d9ca9521ef21316a4e00f9d" | ||
27 | |||
28 | UPSTREAM_CHECK_URI = "http://www.jedsoft.org/releases/slang/" | ||
29 | PREMIRRORS_append = "\n http://www.jedsoft.org/releases/slang/.* http://www.jedsoft.org/releases/slang/old/ \n" | ||
30 | |||
31 | inherit autotools-brokensep | ||
32 | CLEANBROKEN = "1" | ||
33 | |||
34 | EXTRA_OECONF = "--without-onig" | ||
35 | |||
36 | PACKAGECONFIG ??= "pcre" | ||
37 | PACKAGECONFIG[pcre] = "--with-pcre,--without-pcre,pcre" | ||
38 | PACKAGECONFIG[png] = "--with-png,--without-png,libpng" | ||
39 | PACKAGECONFIG[zlib] = "--with-z,--without-z,zlib" | ||
40 | |||
41 | do_configure_prepend() { | ||
42 | # slang keeps configure.ac and rest of autoconf files in autoconf/ directory | ||
43 | # we have to go there to be able to run gnu-configize cause it expects configure.{in,ac} | ||
44 | # to be present. Resulting files land in autoconf/autoconf/ so we need to move them. | ||
45 | cd ${S}/autoconf && gnu-configize --force && mv autoconf/config.* . | ||
46 | cd ${B} | ||
47 | } | ||
48 | |||
49 | do_install() { | ||
50 | oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib' | ||
51 | } | ||
52 | |||
53 | FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/" | ||
54 | |||
55 | PARALLEL_MAKE = "" | ||
56 | PARALLEL_MAKEINST = "" | ||
57 | |||
58 | BBCLASSEXTEND = "native" | ||