summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang/slang_2.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.3.1.bb')
-rw-r--r--meta/recipes-extended/slang/slang_2.3.1.bb23
1 files changed, 11 insertions, 12 deletions
diff --git a/meta/recipes-extended/slang/slang_2.3.1.bb b/meta/recipes-extended/slang/slang_2.3.1.bb
index 7bf3af6836..3a5030354c 100644
--- a/meta/recipes-extended/slang/slang_2.3.1.bb
+++ b/meta/recipes-extended/slang/slang_2.3.1.bb
@@ -14,12 +14,9 @@ DEPENDS = "ncurses virtual/libiconv"
14LICENSE = "GPLv2" 14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02" 15LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
16 16
17
18SRC_URI = "http://www.jedsoft.org/releases/${BPN}/${BP}.tar.bz2 \ 17SRC_URI = "http://www.jedsoft.org/releases/${BPN}/${BP}.tar.bz2 \
19 file://rpathfix.patch \
20 file://fix-check-pcre.patch \
21 file://slang-fix-the-iconv-existence-checking.patch \
22 file://no-x.patch \ 18 file://no-x.patch \
19 file://dont-link-to-host.patch \
23 " 20 "
24 21
25SRC_URI[md5sum] = "bd46d1dc17a50c72004ad842829d7b1f" 22SRC_URI[md5sum] = "bd46d1dc17a50c72004ad842829d7b1f"
@@ -32,24 +29,26 @@ inherit autotools-brokensep
32CLEANBROKEN = "1" 29CLEANBROKEN = "1"
33 30
34EXTRA_OECONF = "--without-onig" 31EXTRA_OECONF = "--without-onig"
32# There's no way to turn off rpaths and slang will -rpath to the default search
33# path. Unset RPATH to stop this.
34EXTRA_OEMAKE = "RPATH=''"
35 35
36PACKAGECONFIG ??= "pcre" 36PACKAGECONFIG ??= "pcre"
37PACKAGECONFIG[pcre] = "--with-pcre,--without-pcre,pcre" 37PACKAGECONFIG[pcre] = "--with-pcre=${STAGING_DIR_HOST}${prefix},--without-pcre,pcre"
38PACKAGECONFIG[png] = "--with-png,--without-png,libpng" 38PACKAGECONFIG[png] = "--with-png=${STAGING_DIR_HOST}${prefix},--without-png,libpng"
39PACKAGECONFIG[zlib] = "--with-z,--without-z,zlib" 39PACKAGECONFIG[zlib] = "--with-z=${STAGING_DIR_HOST}${prefix},--without-z,zlib"
40 40
41do_configure_prepend() { 41do_configure_prepend() {
42 cd ${S}/autoconf
42 # slang keeps configure.ac and rest of autoconf files in autoconf/ directory 43 # slang keeps configure.ac and rest of autoconf files in autoconf/ directory
43 # we have to go there to be able to run gnu-configize cause it expects configure.{in,ac} 44 # we have to go there to be able to run gnu-configize cause it expects configure.{in,ac}
44 # to be present. Resulting files land in autoconf/autoconf/ so we need to move them. 45 # to be present. Resulting files land in autoconf/autoconf/ so we need to move them.
45 cd ${S}/autoconf && gnu-configize --force && mv autoconf/config.* . 46 gnu-configize --force && mv autoconf/config.* .
47 # For the same reason we also need to run autoconf manually.
48 autoconf && mv configure ..
46 cd ${B} 49 cd ${B}
47} 50}
48 51
49do_install() {
50 oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
51}
52
53FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/" 52FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/"
54 53
55PARALLEL_MAKE = "" 54PARALLEL_MAKE = ""