summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang/slang_2.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.3.0.bb')
-rw-r--r--meta/recipes-extended/slang/slang_2.3.0.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-extended/slang/slang_2.3.0.bb b/meta/recipes-extended/slang/slang_2.3.0.bb
new file mode 100644
index 0000000000..17efbbe223
--- /dev/null
+++ b/meta/recipes-extended/slang/slang_2.3.0.bb
@@ -0,0 +1,51 @@
1SUMMARY = "The shared library for the S-Lang extension language"
2
3DESCRIPTION = "S-Lang is an interpreted language and a programming library. The \
4S-Lang language was designed so that it can be easily embedded into \
5a program to provide the program with a powerful extension language. \
6The S-Lang library, provided in this package, provides the S-Lang \
7extension language. S-Lang's syntax resembles C, which makes it easy \
8to recode S-Lang procedures in C if you need to."
9
10HOMEPAGE = "http://www.jedsoft.org/slang/"
11SECTION = "libs"
12DEPENDS = "pcre ncurses"
13
14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
16
17
18SRC_URI = "http://www.jedsoft.org/releases/${BPN}/${BP}.tar.bz2 \
19 file://rpathfix.patch \
20 file://fix-check-pcre.patch \
21 file://slang-fix-the-iconv-existence-checking.patch \
22 file://0001-Fix-error-conflicting-types-for-posix_close.patch \
23 "
24UPSTREAM_CHECK_URI = "http://www.jedsoft.org/releases/slang/"
25
26inherit autotools-brokensep
27
28CLEANBROKEN = "1"
29
30SRC_URI[md5sum] = "3bcc790460d52db1316c20395b7ac2f1"
31SRC_URI[sha256sum] = "f95224060f45e0d8212a5039b339afa5f1a94a1bb0298e796104e5b12e926129"
32
33EXTRA_OECONF += " --without-z --without-png --without-onig --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib"
34
35do_configure_prepend() {
36 # slang keeps configure.ac and rest of autoconf files in autoconf/ directory
37 # we have to go there to be able to run gnu-configize cause it expects configure.{in,ac}
38 # to be present. Resulting files land in autoconf/autoconf/ so we need to move them.
39 cd ${S}/autoconf && gnu-configize --force && mv autoconf/config.* .
40 cd ${B}
41}
42
43do_install() {
44 oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
45}
46
47FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/"
48
49PARALLEL_MAKE = ""
50
51BBCLASSEXTEND = "native"