summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/slang/slang_2.2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/slang/slang_2.2.4.bb')
-rw-r--r--meta/recipes-extended/slang/slang_2.2.4.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/slang/slang_2.2.4.bb b/meta/recipes-extended/slang/slang_2.2.4.bb
new file mode 100644
index 0000000000..f3003c9f08
--- /dev/null
+++ b/meta/recipes-extended/slang/slang_2.2.4.bb
@@ -0,0 +1,49 @@
1SUMMARY = "The shared library for the S-Lang extension language"
2
3DESCRIPTION = "S-Lang is an interpreted language and a programming library. The \
4S-Lang language was designed so that it can be easily embedded into \
5a program to provide the program with a powerful extension language. \
6The S-Lang library, provided in this package, provides the S-Lang \
7extension language. S-Lang's syntax resembles C, which makes it easy \
8to recode S-Lang procedures in C if you need to."
9
10HOMEPAGE = "http://www.jedsoft.org/slang/"
11SECTION = "libs"
12DEPENDS = "pcre"
13PR = "r12"
14
15LICENSE = "GPLv2"
16LIC_FILES_CHKSUM = "file://COPYING;md5=a52a18a472d4f7e45479b06563717c02"
17
18
19SRC_URI = "ftp://space.mit.edu/pub/davis/slang/v2.2/slang-${PV}.tar.bz2 \
20 file://rpathfix.patch \
21 file://fix-check-pcre.patch \
22 file://change-char-type-to-signed-char-in-macros.patch \
23 file://sprintf-bug-concerning-8-bit-characters.patch \
24 file://slang-fix-the-iconv-existence-checking.patch \
25 "
26
27inherit autotools-brokensep
28
29SRC_URI[md5sum] = "7fcfd447e378f07dd0c0bae671fe6487"
30SRC_URI[sha256sum] = "9a8257a9a2a55099af858b13338dc8f3a06dd2069f46f0df2c9c3bb84a01d5db"
31
32EXTRA_OECONF += " --without-z --without-png --without-onig --x-includes=${STAGING_DIR_HOST}/usr/include/X11 --x-libraries=${STAGING_DIR_HOST}/usr/lib"
33
34do_configure_prepend() {
35 # slang keeps configure.ac and rest of autoconf files in autoconf/ directory
36 # we have to go there to be able to run gnu-configize cause it expects configure.{in,ac}
37 # to be present. Resulting files land in autoconf/autoconf/ so we need to move them.
38 cd ${S}/autoconf && gnu-configize --force && mv autoconf/config.* .
39 cd ${B}
40}
41
42do_install() {
43 oe_runmake install DESTDIR=${D} -e 'INST_LIB_DIR=${STAGING_DIR_HOST}/usr/lib'
44}
45
46FILES_${PN} += "${libdir}/${BPN}/v2/modules/ ${datadir}/slsh/"
47FILES_${PN}-dbg += "${libdir}/${BPN}/v2/modules/.debug"
48
49PARALLEL_MAKE = ""