summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/shadow/shadow-sysroot_4.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/shadow/shadow-sysroot_4.2.1.bb')
-rw-r--r--meta/recipes-extended/shadow/shadow-sysroot_4.2.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/shadow/shadow-sysroot_4.2.1.bb b/meta/recipes-extended/shadow/shadow-sysroot_4.2.1.bb
new file mode 100644
index 0000000000..697569c47e
--- /dev/null
+++ b/meta/recipes-extended/shadow/shadow-sysroot_4.2.1.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Shadow utils requirements for useradd.bbclass"
2HOMEPAGE = "http://pkg-shadow.alioth.debian.org"
3BUGTRACKER = "https://alioth.debian.org/tracker/?group_id=30580"
4SECTION = "base utils"
5LICENSE = "BSD | Artistic-1.0"
6LIC_FILES_CHKSUM = "file://login.defs_shadow-sysroot;md5=25e2f2de4dfc8f966ac5cdfce45cd7d5"
7
8DEPENDS = "base-passwd"
9
10PR = "r3"
11
12# The sole purpose of this recipe is to provide the /etc/login.defs
13# file for the target sysroot - needed so the shadow-native utilities
14# can add custom users/groups for recipes that use inherit useradd.
15SRC_URI = "file://login.defs_shadow-sysroot"
16
17SRC_URI[md5sum] = "b8608d8294ac88974f27b20f991c0e79"
18SRC_URI[sha256sum] = "633f5bb4ea0c88c55f3642c97f9d25cbef74f82e0b4cf8d54e7ad6f9f9caa778"
19
20S = "${WORKDIR}"
21
22do_install() {
23 install -d ${D}${sysconfdir}
24 install -p -m 755 ${S}/login.defs_shadow-sysroot ${D}${sysconfdir}/login.defs
25}
26
27sysroot_stage_all() {
28 sysroot_stage_dir ${D} ${SYSROOT_DESTDIR}
29}
30
31# don't create any packages
32# otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot
33# and this has another copy of /etc/login.defs already provided by shadow
34PACKAGES = ""