summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/sat-solver/sat-solver_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/sat-solver/sat-solver_git.bb')
-rw-r--r--meta/recipes-extended/sat-solver/sat-solver_git.bb67
1 files changed, 0 insertions, 67 deletions
diff --git a/meta/recipes-extended/sat-solver/sat-solver_git.bb b/meta/recipes-extended/sat-solver/sat-solver_git.bb
deleted file mode 100644
index 67503b7278..0000000000
--- a/meta/recipes-extended/sat-solver/sat-solver_git.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1DESCRIPTION = "Sat Solver"
2HOMEPAGE = "http://http://en.opensuse.org/openSUSE:Libzypp_satsolver"
3
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
6
7DEPENDS = "libcheck rpm zlib expat db"
8
9SRCREV = "0a7378d5f482f477a01cf1690d76871ab8bdcc32"
10PV = "0.0-git${SRCPV}"
11PR = "r14"
12
13PARALLEL_MAKE=""
14
15SRC_URI = "git://github.com/openSUSE/sat-solver.git;protocol=git \
16 file://sat-solver_rpm5.patch \
17 file://sat-solver_obsolete.patch \
18 file://cmake.patch \
19 file://db5.patch \
20 file://sat-solver_core.patch \
21 file://fix_gcc-4.6.0_compile_issue.patch \
22 file://0001-sat_xfopen.c-Forward-port-to-zlib-1.2.6-gzFile.patch \
23 file://futimes.patch \
24 "
25
26S = "${WORKDIR}/git"
27
28EXTRA_OECMAKE += "-DRPM5=RPM5 -DOE_CORE=OE_CORE"
29
30EXTRA_OECMAKE += " -DLIB=${@os.path.basename('${libdir}')}"
31
32TUNE_CCARGS_append_libc-uclibc = " -DUSE_OWN_QSORT=1 "
33
34inherit cmake pkgconfig
35
36RDEPENDS_${PN} = "rpm-libs"
37
38PACKAGE_ARCH = "${MACHINE_ARCH}"
39
40do_archgen () {
41 # We need to dynamically generate our arch file based on the machine
42 # configuration
43
44 INSTALL_PLATFORM_ARCHS=""
45 for each_arch in ${PACKAGE_ARCHS} ; do
46 case "$each_arch" in
47 all | any | noarch)
48 continue;;
49 esac
50 INSTALL_PLATFORM_ARCHS="`echo $each_arch | sed 's/-/_/g'` $INSTALL_PLATFORM_ARCHS"
51 done
52
53 echo "/* Automatically generated by the sat-solver recipe */" > src/core-arch.h
54 echo "const char *archpolicies[] = {" >> src/core-arch.h
55
56 set -- $INSTALL_PLATFORM_ARCHS
57
58 save_IFS=$IFS
59 IFS=:
60 while [ $# -gt 0 ]; do echo " \"$1\", "\""$*"\", >> src/core-arch.h ; shift; done
61 IFS=$save_IFS
62
63 echo " 0" >> src/core-arch.h
64 echo "};" >> src/core-arch.h
65}
66
67addtask archgen before do_configure after do_patch