summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/quota/quota_4.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/quota/quota_4.02.bb')
-rw-r--r--meta/recipes-extended/quota/quota_4.02.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/quota/quota_4.02.bb b/meta/recipes-extended/quota/quota_4.02.bb
new file mode 100644
index 0000000000..020ed3528c
--- /dev/null
+++ b/meta/recipes-extended/quota/quota_4.02.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Tools for monitoring & limiting user disk usage per filesystem"
2SECTION = "base"
3HOMEPAGE = "http://sourceforge.net/projects/linuxquota/"
4BUGTRACKER = "http://sourceforge.net/tracker/?group_id=18136&atid=118136"
5LICENSE = "BSD & GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://quota.c;beginline=1;endline=33;md5=331c7d77744bfe0ad24027f0651028ec \
7 file://rquota_server.c;beginline=1;endline=20;md5=fe7e0d7e11c6f820f8fa62a5af71230f \
8 file://svc_socket.c;beginline=1;endline=17;md5=24d5a8792da45910786eeac750be8ceb"
9SRC_URI = "${SOURCEFORGE_MIRROR}/project/linuxquota/quota-tools/${PV}/quota-${PV}.tar.gz \
10 file://config-tcpwrappers.patch"
11SRC_URI[md5sum] = "a8a5df262261e659716ccad2a5d6df0d"
12SRC_URI[sha256sum] = "f4c2f48abf94bbdc396df33d276f2e9d19af58c232cb85eef9c174a747c33795"
13
14S = "${WORKDIR}/quota-tools"
15
16DEPENDS = "gettext-native e2fsprogs"
17
18inherit autotools-brokensep gettext pkgconfig
19
20EXTRA_OEMAKE += 'STRIP=""'
21
22PACKAGECONFIG ??= "tcp-wrappers"
23PACKAGECONFIG[tcp-wrappers] = "--with-tcpwrappers,--without-tcpwrappers,tcp-wrappers"
24
25do_install() {
26 oe_runmake prefix=${D}${prefix} install
27}