summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/quota/quota_4.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/quota/quota_4.01.bb')
-rw-r--r--meta/recipes-extended/quota/quota_4.01.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/quota/quota_4.01.bb b/meta/recipes-extended/quota/quota_4.01.bb
new file mode 100644
index 0000000000..82f7899690
--- /dev/null
+++ b/meta/recipes-extended/quota/quota_4.01.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Tools for monitoring & limiting user disk usage per filesystem"
2SECTION = "base"
3HOMEPAGE = "http://sourceforge.net/projects/linuxquota/"
4BUGTRACKER = "http://sourceforge.net/tracker/?group_id=18136&atid=118136"
5LICENSE = "BSD & GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://quota.c;beginline=1;endline=33;md5=331c7d77744bfe0ad24027f0651028ec \
7 file://rquota_server.c;beginline=1;endline=20;md5=fe7e0d7e11c6f820f8fa62a5af71230f \
8 file://svc_socket.c;beginline=1;endline=17;md5=24d5a8792da45910786eeac750be8ceb"
9PR = "r1"
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/project/linuxquota/quota-tools/${PV}/quota-${PV}.tar.gz \
12 file://config-tcpwrappers.patch"
13
14SRC_URI[md5sum] = "5c2c31e321d2e1322ce12d69ae5c66d6"
15SRC_URI[sha256sum] = "a36300bbc126b79b745bf937245092808b4585aa3309ef3335d4ab9d873cd206"
16
17S = "${WORKDIR}/quota-tools"
18
19DEPENDS = "gettext-native e2fsprogs"
20
21inherit autotools-brokensep gettext pkgconfig
22
23EXTRA_OEMAKE += 'STRIP=""'
24
25PACKAGECONFIG ??= "tcp-wrappers"
26PACKAGECONFIG[tcp-wrappers] = "--with-tcpwrappers,--without-tcpwrappers,tcp-wrappers"
27
28do_install() {
29 oe_runmake prefix=${D}${prefix} install
30}