summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/procps/procps_3.3.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/procps/procps_3.3.16.bb')
-rw-r--r--meta/recipes-extended/procps/procps_3.3.16.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/meta/recipes-extended/procps/procps_3.3.16.bb b/meta/recipes-extended/procps/procps_3.3.16.bb
new file mode 100644
index 0000000000..60f90976bb
--- /dev/null
+++ b/meta/recipes-extended/procps/procps_3.3.16.bb
@@ -0,0 +1,71 @@
1SUMMARY = "System and process monitoring utilities"
2DESCRIPTION = "Procps contains a set of system utilities that provide system information about processes using \
3the /proc filesystem. The package includes the programs ps, top, vmstat, w, kill, and skill."
4HOMEPAGE = "https://gitlab.com/procps-ng/procps"
5SECTION = "base"
6LICENSE = "GPLv2+ & LGPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://COPYING.LIB;md5=4cf66a4984120007c9881cc871cf49db \
9 "
10
11DEPENDS = "ncurses"
12
13inherit autotools gettext pkgconfig update-alternatives
14
15SRC_URI = "http://downloads.sourceforge.net/project/procps-ng/Production/procps-ng-${PV}.tar.xz \
16 file://sysctl.conf \
17 "
18
19SRC_URI[md5sum] = "e8dc8455e573bdc40b8381d572bbb89b"
20SRC_URI[sha256sum] = "925eacd65dedcf9c98eb94e8978bbfb63f5de37294cc1047d81462ed477a20af"
21
22S = "${WORKDIR}/procps-ng-${PV}"
23
24EXTRA_OECONF = "--enable-skill --disable-modern-top"
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
27PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd"
28
29do_install_append () {
30 install -d ${D}${base_bindir}
31 [ "${bindir}" != "${base_bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i; done
32 install -d ${D}${base_sbindir}
33 [ "${sbindir}" != "${base_sbindir}" ] && for i in ${base_sbindir_progs}; do mv ${D}${sbindir}/$i ${D}${base_sbindir}/$i; done
34 if [ "${base_sbindir}" != "${sbindir}" ]; then
35 rmdir ${D}${sbindir}
36 fi
37
38 install -d ${D}${sysconfdir}
39 install -m 0644 ${WORKDIR}/sysctl.conf ${D}${sysconfdir}/sysctl.conf
40 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
41 install -d ${D}${sysconfdir}/sysctl.d
42 ln -sf ../sysctl.conf ${D}${sysconfdir}/sysctl.d/99-sysctl.conf
43 fi
44}
45
46CONFFILES_${PN} = "${sysconfdir}/sysctl.conf"
47
48bindir_progs = "free pkill pmap pgrep pwdx skill snice top uptime w"
49base_bindir_progs += "kill pidof ps watch"
50base_sbindir_progs += "sysctl"
51
52ALTERNATIVE_PRIORITY = "200"
53ALTERNATIVE_PRIORITY[pidof] = "150"
54
55ALTERNATIVE_${PN} = "${bindir_progs} ${base_bindir_progs} ${base_sbindir_progs}"
56
57ALTERNATIVE_${PN}-doc = "kill.1 uptime.1"
58ALTERNATIVE_LINK_NAME[kill.1] = "${mandir}/man1/kill.1"
59ALTERNATIVE_LINK_NAME[uptime.1] = "${mandir}/man1/uptime.1"
60
61python __anonymous() {
62 for prog in d.getVar('base_bindir_progs').split():
63 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir'), prog))
64
65 for prog in d.getVar('base_sbindir_progs').split():
66 d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_sbindir'), prog))
67}
68
69# 'ps' isn't suitable for use as a security tool so whitelist this CVE.
70# https://bugzilla.redhat.com/show_bug.cgi?id=1575473#c3
71CVE_CHECK_WHITELIST += "CVE-2018-1121"