diff options
Diffstat (limited to 'meta/recipes-extended/procps/procps_3.3.10.bb')
-rw-r--r-- | meta/recipes-extended/procps/procps_3.3.10.bb | 62 |
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-extended/procps/procps_3.3.10.bb b/meta/recipes-extended/procps/procps_3.3.10.bb new file mode 100644 index 0000000000..d8b04dc204 --- /dev/null +++ b/meta/recipes-extended/procps/procps_3.3.10.bb | |||
@@ -0,0 +1,62 @@ | |||
1 | SUMMARY = "System and process monitoring utilities" | ||
2 | DESCRIPTION = "Procps contains a set of system utilities that provide system information about processes using \ | ||
3 | the /proc filesystem. The package includes the programs ps, top, vmstat, w, kill, and skill." | ||
4 | HOMEPAGE = "https://gitorious.org/procps" | ||
5 | SECTION = "base" | ||
6 | LICENSE = "GPLv2+ & LGPLv2+" | ||
7 | LIC_FILES_CHKSUM="file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
8 | file://COPYING.LIB;md5=4cf66a4984120007c9881cc871cf49db \ | ||
9 | " | ||
10 | |||
11 | DEPENDS = "ncurses" | ||
12 | |||
13 | inherit autotools gettext pkgconfig update-alternatives | ||
14 | |||
15 | SRC_URI = "http://downloads.sourceforge.net/project/procps-ng/Production/procps-ng-${PV}.tar.xz \ | ||
16 | file://fix-configure.patch \ | ||
17 | file://sysctl.conf \ | ||
18 | " | ||
19 | |||
20 | SRC_URI[md5sum] = "1fb7f3f6bf92ce6c5c9ed9949ae858fe" | ||
21 | SRC_URI[sha256sum] = "a02e6f98974dfceab79884df902ca3df30b0e9bad6d76aee0fb5dce17f267f04" | ||
22 | |||
23 | S = "${WORKDIR}/procps-ng-${PV}" | ||
24 | |||
25 | EXTRA_OECONF = "--enable-skill" | ||
26 | |||
27 | CPPFLAGS += "-I${S}" | ||
28 | |||
29 | do_install_append () { | ||
30 | install -d ${D}${base_bindir} | ||
31 | [ "${bindir}" != "${base_bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i; done | ||
32 | install -d ${D}${base_sbindir} | ||
33 | [ "${sbindir}" != "${base_sbindir}" ] && for i in ${base_sbindir_progs}; do mv ${D}${sbindir}/$i ${D}${base_sbindir}/$i; done | ||
34 | # Remove now empty dir | ||
35 | rmdir ${D}/${sbindir} | ||
36 | |||
37 | install -d ${D}${sysconfdir} | ||
38 | install -m 0644 ${WORKDIR}/sysctl.conf ${D}${sysconfdir}/sysctl.conf | ||
39 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
40 | install -d ${D}${sysconfdir}/sysctl.d | ||
41 | ln -sf ../sysctl.conf ${D}${sysconfdir}/sysctl.d/99-sysctl.conf | ||
42 | fi | ||
43 | } | ||
44 | |||
45 | CONFFILES_${PN} = "${sysconfdir}/sysctl.conf" | ||
46 | |||
47 | bindir_progs = "free pkill pmap pgrep pwdx skill snice top uptime" | ||
48 | base_bindir_progs += "kill pidof ps watch" | ||
49 | base_sbindir_progs += "sysctl" | ||
50 | |||
51 | ALTERNATIVE_PRIORITY = "100" | ||
52 | |||
53 | ALTERNATIVE_${PN} = "${bindir_progs} ${base_bindir_progs} ${base_sbindir_progs}" | ||
54 | |||
55 | python __anonymous() { | ||
56 | for prog in d.getVar('base_bindir_progs', True).split(): | ||
57 | d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_bindir', True), prog)) | ||
58 | |||
59 | for prog in d.getVar('base_sbindir_progs', True).split(): | ||
60 | d.setVarFlag('ALTERNATIVE_LINK_NAME', prog, '%s/%s' % (d.getVar('base_sbindir', True), prog)) | ||
61 | } | ||
62 | |||