diff options
Diffstat (limited to 'meta/recipes-extended/procps/procps_3.2.8.bb')
-rw-r--r-- | meta/recipes-extended/procps/procps_3.2.8.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/procps/procps_3.2.8.bb b/meta/recipes-extended/procps/procps_3.2.8.bb new file mode 100644 index 0000000000..32d812443f --- /dev/null +++ b/meta/recipes-extended/procps/procps_3.2.8.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | require procps.inc | ||
2 | |||
3 | PR = "r0" | ||
4 | |||
5 | inherit update-rc.d update-alternatives | ||
6 | |||
7 | INITSCRIPT_NAME = "procps.sh" | ||
8 | INITSCRIPT_PARAMS = "start 30 S ." | ||
9 | |||
10 | ALTERNATIVE_LINKS = "${bindir}/top ${bindir}/uptime ${bindir}/free ${bindir}/pkill \ | ||
11 | ${base_bindir}/kill ${base_sbindir}/sysctl ${base_bindir}/ps" | ||
12 | ALTERNATIVE_PRIORITY = "90" | ||
13 | |||
14 | SRC_URI += "file://procmodule.patch \ | ||
15 | file://psmodule.patch \ | ||
16 | file://linux-limits.patch \ | ||
17 | file://sysctl.conf \ | ||
18 | file://procps.init \ | ||
19 | file://procps-3.2.8+gmake-3.82.patch \ | ||
20 | " | ||
21 | |||
22 | FILES = "${bindir}/top.${PN} ${base_bindir}/ps.${PN} ${bindir}/uptime.${PN} ${base_bindir}/kill.${PN} \ | ||
23 | ${bindir}/free.${PN} ${bindir}/w ${bindir}/watch ${bindir}/pgrep ${bindir}/pmap ${bindir}/pwdx \ | ||
24 | ${bindir}/snice ${bindir}/vmstat ${bindir}/slabtop ${bindir}/pkill ${bindir}/skill ${bindir}/tload \ | ||
25 | ${base_sbindir}/sysctl.${PN}" | ||
26 | |||
27 | CONFFILES_${PN} = "${sysconfdir}/sysctl.conf" | ||
28 | |||
29 | EXTRA_OEMAKE = "CFLAGS=-I${STAGING_INCDIR} \ | ||
30 | CPPFLAGS=-I${STAGING_INCDIR} \ | ||
31 | LDFLAGS="${LDFLAGS}" \ | ||
32 | CURSES=-lncurses \ | ||
33 | install='install -D' \ | ||
34 | ldconfig=echo" | ||
35 | |||
36 | do_install_append () { | ||
37 | install -d ${D}${sysconfdir} | ||
38 | install -m 0644 ${WORKDIR}/sysctl.conf ${D}${sysconfdir}/sysctl.conf | ||
39 | install -d ${D}${sysconfdir}/init.d | ||
40 | install -m 0755 ${WORKDIR}/procps.init ${D}${sysconfdir}/init.d/procps.sh | ||
41 | } | ||