summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/polkit/polkit_0.104.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/polkit/polkit_0.104.bb')
-rw-r--r--meta/recipes-extended/polkit/polkit_0.104.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/polkit/polkit_0.104.bb b/meta/recipes-extended/polkit/polkit_0.104.bb
new file mode 100644
index 0000000000..e51e0174a1
--- /dev/null
+++ b/meta/recipes-extended/polkit/polkit_0.104.bb
@@ -0,0 +1,33 @@
1SUMMARY = "PolicyKit Authorization Framework"
2DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
3HOMEPAGE = "http://code.google.com/p/polkit/"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4 \
7 file://docs/polkit/html/license.html;md5=d85a36709a446c10f4ee123f9dda0e38"
8
9SRC_URI = "http://hal.freedesktop.org/releases/polkit-${PV}.tar.gz \
10 file://introspection.patch \
11 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
12
13SRC_URI[md5sum] = "e380b4c6fb1e7bccf854e92edc0a8ce1"
14SRC_URI[sha256sum] = "6b0a13d8381e4a7b7e37c18a54595191b50757e0fcd186cd9918e9ad0f18c7f9"
15
16PAM_SRC_URI = "file://polkit-1_pam.patch"
17PR = "r0"
18DEPENDS = "libpam expat dbus-glib eggdbus intltool-native"
19RDEPENDS_${PN} = "libpam"
20EXTRA_OECONF = "--with-authfw=pam --with-os-type=moblin --disable-man-pages --disable-gtk-doc --disable-introspection"
21
22inherit autotools pkgconfig
23
24FILES_${PN} += "${libdir}/${PN}-1/extensions/*.so \
25 ${datadir}/${PN}-1/actions/* \
26 ${datadir}/dbus-1/system-services/*"
27FILES_${PN}-dbg += "${libdir}/${PN}-1/extensions/.debug/*.so"
28FILES_${PN}-dev += "${libdir}/${PN}-1/extensions/*.la "
29
30do_install_append() {
31 rm -f ${D}${libdir}/${PN}-1/extensions/*.a
32}
33