summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/polkit/polkit_0.104.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/polkit/polkit_0.104.bb')
-rw-r--r--meta/recipes-extended/polkit/polkit_0.104.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/meta/recipes-extended/polkit/polkit_0.104.bb b/meta/recipes-extended/polkit/polkit_0.104.bb
deleted file mode 100644
index 342fbe1c52..0000000000
--- a/meta/recipes-extended/polkit/polkit_0.104.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1SUMMARY = "PolicyKit Authorization Framework"
2DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
7
8DEPENDS = "expat glib-2.0 intltool-native gobject-introspection-stub"
9
10PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
11 ${@base_contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}"
12
13PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
14PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
15# There is no --enable/--disable option for consolekit, so disable systemd to
16# force it. ConsoleKit is accessed via DBus, so add it to RDEPENDS.
17PACKAGECONFIG[consolekit] = "--disable-systemd,,,consolekit"
18
19PR = "r9"
20
21PAM_SRC_URI = "file://polkit-1_pam.patch"
22SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
23 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
24 file://0001-PolkitUnixSession-Set-error-if-we-cannot-find-a-sess.patch \
25 file://0002-PolkitUnixSession-Actually-return-TRUE-if-a-session-.patch \
26 file://obsolete_automake_macros.patch \
27 "
28
29SRC_URI[md5sum] = "e380b4c6fb1e7bccf854e92edc0a8ce1"
30SRC_URI[sha256sum] = "6b0a13d8381e4a7b7e37c18a54595191b50757e0fcd186cd9918e9ad0f18c7f9"
31
32EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages --disable-introspection"
33
34inherit autotools gtk-doc pkgconfig
35
36do_install_append() {
37 rm -f ${D}${libdir}/${BPN}-1/extensions/*.a
38}
39
40FILES_${PN} += "${libdir}/${BPN}-1/extensions/*.so \
41 ${datadir}/${BPN}-1/actions/* \
42 ${datadir}/dbus-1/system-services/*"
43FILES_${PN}-dbg += "${libdir}/${BPN}-1/extensions/.debug/*.so"
44FILES_${PN}-dev += "${libdir}/${BPN}-1/extensions/*.la "
45