diff options
Diffstat (limited to 'meta/recipes-extended/pigz/pigz_2.4.bb')
-rw-r--r-- | meta/recipes-extended/pigz/pigz_2.4.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/pigz/pigz_2.4.bb b/meta/recipes-extended/pigz/pigz_2.4.bb new file mode 100644 index 0000000000..cb41154daf --- /dev/null +++ b/meta/recipes-extended/pigz/pigz_2.4.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | SUMMARY = "A parallel implementation of gzip" | ||
2 | DESCRIPTION = "pigz, which stands for parallel implementation of gzip, is a \ | ||
3 | fully functional replacement for gzip that exploits multiple processors and \ | ||
4 | multiple cores to the hilt when compressing data. pigz was written by Mark \ | ||
5 | Adler, and uses the zlib and pthread libraries." | ||
6 | HOMEPAGE = "http://zlib.net/pigz/" | ||
7 | SECTION = "console/utils" | ||
8 | LICENSE = "Zlib & Apache-2.0" | ||
9 | LIC_FILES_CHKSUM = "file://pigz.c;md5=9ae6dee8ceba9610596ed0ada493d142;beginline=7;endline=21" | ||
10 | |||
11 | PROVIDES_class-native += "gzip-native" | ||
12 | |||
13 | SRC_URI = "https://github.com/madler/pigz/archive/v${PV}.tar.gz;downloadfilename=${BP}.tar.gz" | ||
14 | SRC_URI[md5sum] = "3c8a601db141d3013ef9fe5f2daaf73f" | ||
15 | SRC_URI[sha256sum] = "e228e7d18b34c4ece8d596eb6eee97bde533c6beedbb728d07d3abe90b4b1b52" | ||
16 | |||
17 | UPSTREAM_CHECK_URI = "http://zlib.net/${BPN}/" | ||
18 | UPSTREAM_CHECK_REGEX = "pigz-(?P<pver>.*)\.tar" | ||
19 | |||
20 | DEPENDS = "zlib" | ||
21 | |||
22 | EXTRA_OEMAKE = "-e MAKEFLAGS=" | ||
23 | |||
24 | inherit update-alternatives | ||
25 | |||
26 | do_install_class-target() { | ||
27 | # Install files into /bin (FHS), which is typical place for gzip | ||
28 | install -d ${D}${base_bindir} | ||
29 | install ${B}/pigz ${D}${base_bindir}/pigz | ||
30 | ln -nsf pigz ${D}${base_bindir}/unpigz | ||
31 | ln -nsf pigz ${D}${base_bindir}/pigzcat | ||
32 | } | ||
33 | |||
34 | do_install() { | ||
35 | install -d ${D}${bindir} | ||
36 | install ${B}/pigz ${D}${bindir}/gzip | ||
37 | ln -nsf gzip ${D}${bindir}/gunzip | ||
38 | ln -nsf gzip ${D}${bindir}/zcat | ||
39 | } | ||
40 | |||
41 | ALTERNATIVE_PRIORITY = "80" | ||
42 | ALTERNATIVE_${PN} = "gunzip gzip zcat" | ||
43 | ALTERNATIVE_${PN}_class-nativesdk = "" | ||
44 | ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip" | ||
45 | ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip" | ||
46 | ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat" | ||
47 | ALTERNATIVE_TARGET = "${base_bindir}/pigz" | ||
48 | |||
49 | BBCLASSEXTEND = "native nativesdk" | ||