summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.9.bb')
-rw-r--r--meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.9.bb35
1 files changed, 0 insertions, 35 deletions
diff --git a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.9.bb b/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.9.bb
deleted file mode 100644
index a7d26ea38c..0000000000
--- a/meta/recipes-extended/perl/libxml-namespacesupport-perl_1.12.9.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1SUMMARY = "Perl module for supporting simple generic namespaces"
2HOMEPAGE = "http://veillard.com/XML/"
3DESCRIPTION = "XML::NamespaceSupport offers a simple way to process namespace-based XML names. \
4 It also helps maintain a prefix-to-namespace URI map, and provides a number of \
5 basic checks. "
6
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9PR = "r3"
10
11LIC_FILES_CHKSUM = "file://META.yml;beginline=22;endline=22;md5=9ca1a4a941496e7feedac72c4fb8b137"
12
13# the upstream project complicate a bit url generartion on point release, using a underscore
14# instead of a point on URL, i.e 1.12_9 instead of 1.12.9
15python () {
16 baseurl = "http://search.cpan.org/CPAN/authors/id/P/PE/PERIGRIN/XML-NamespaceSupport"
17 pv = d.getVar('PV')
18 pvsplit = pv.split('.')
19
20 if len(pvsplit) != 3:
21 d.setVar('SRC_URI', "%s-%s.tar.gz" % (baseurl, pv))
22 d.setVar('S', "${WORKDIR}/XML-NamespaceSupport-${PV}")
23 else:
24 pvx, pvy, pvz = pvsplit
25 d.setVar('SRC_URI', "%s-%s.%s_%s.tar.gz" % (baseurl, pvx, pvy, pvz))
26 d.setVar('S', "${WORKDIR}/XML-NamespaceSupport-%s.%s_%s" % (pvx, pvy, pvz))
27}
28
29SRC_URI[md5sum] = "165927a311fb640961b28607035beab8"
30SRC_URI[sha256sum] = "2e84a057f0a8c845a612d212742cb94fca4fc8a433150b5721bd448f77d1e4a9"
31
32inherit cpan
33
34BBCLASSEXTEND="native"
35