summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb')
-rw-r--r--meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb b/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb
new file mode 100644
index 0000000000..b3c5975811
--- /dev/null
+++ b/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb
@@ -0,0 +1,30 @@
1SUMMARY = "PBZIP2 is a parallel implementation of bzip2"
2DESCRIPTION = "PBZIP2 is a parallel implementation of the bzip2 block-sorting \
3file compressor that uses pthreads and achieves near-linear speedup on SMP \
4machines. The output of this version is fully compatible with bzip2 v1.0.2 or \
5newer (ie: anything compressed with pbzip2 can be decompressed with bzip2)."
6HOMEPAGE = "http://compression.ca/pbzip2/"
7SECTION = "console/utils"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4c4f2edec9679d5abef3514a816b54a4"
10
11DEPENDS = "bzip2"
12DEPENDS_append_class-native = " bzip2-replacement-native"
13
14SRC_URI = "https://launchpad.net/${BPN}/1.1/${PV}/+download/${BP}.tar.gz"
15
16SRC_URI[md5sum] = "4cb87da2dba05540afce162f34b3a9a6"
17SRC_URI[sha256sum] = "8fd13eaaa266f7ee91f85c1ea97c86d9c9cc985969db9059cdebcb1e1b7bdbe6"
18
19UPSTREAM_CHECK_URI = "http://compression.ca/pbzip2/"
20
21do_configure[noexec] = "1"
22
23EXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'"
24
25do_install() {
26 install -d ${D}${bindir}
27 install -m 0755 pbzip2 ${D}${bindir}/
28}
29
30BBCLASSEXTEND = "native"