summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pbzip2/pbzip2_1.1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/pbzip2/pbzip2_1.1.12.bb')
-rw-r--r--meta/recipes-extended/pbzip2/pbzip2_1.1.12.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/pbzip2/pbzip2_1.1.12.bb b/meta/recipes-extended/pbzip2/pbzip2_1.1.12.bb
new file mode 100644
index 0000000000..fb70d0caa9
--- /dev/null
+++ b/meta/recipes-extended/pbzip2/pbzip2_1.1.12.bb
@@ -0,0 +1,27 @@
1SUMMARY = "PBZIP2 is a parallel implementation of bzip2"
2DESCRIPTION = "PBZIP2 is a parallel implementation of the bzip2 block-sorting \
3file compressor that uses pthreads and achieves near-linear speedup on SMP \
4machines. The output of this version is fully compatible with bzip2 v1.0.2 or \
5newer (ie: anything compressed with pbzip2 can be decompressed with bzip2)."
6HOMEPAGE = "http://compression.ca/pbzip2/"
7SECTION = "console/utils"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4c4f2edec9679d5abef3514a816b54a4"
10
11DEPENDS = "bzip2"
12
13SRC_URI = "https://launchpad.net/${BPN}/1.1/${PV}/+download/${BP}.tar.gz"
14
15SRC_URI[md5sum] = "91a4911b13305850423840eb0fa6f4f9"
16SRC_URI[sha256sum] = "573bb358a5a7d3bf5f42f881af324cedf960c786e8d66dd03d448ddd8a0166ee"
17
18do_configure[noexec] = "1"
19
20EXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'"
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 pbzip2 ${D}${bindir}/
25}
26
27BBCLASSEXTEND = "native"