summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/parted/parted_3.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/parted/parted_3.4.bb')
-rw-r--r--meta/recipes-extended/parted/parted_3.4.bb60
1 files changed, 0 insertions, 60 deletions
diff --git a/meta/recipes-extended/parted/parted_3.4.bb b/meta/recipes-extended/parted/parted_3.4.bb
deleted file mode 100644
index 79dad54687..0000000000
--- a/meta/recipes-extended/parted/parted_3.4.bb
+++ /dev/null
@@ -1,60 +0,0 @@
1SUMMARY = "Disk partition editing/resizing utility"
2HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
5SECTION = "console/tools"
6DEPENDS = "ncurses util-linux virtual/libiconv"
7
8SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
9 file://no_check.patch \
10 file://fix-doc-mandir.patch \
11 file://0002-libparted_fs_resize-link-against-libuuid-explicitly-.patch \
12 file://run-ptest \
13 "
14
15SRC_URI[md5sum] = "357d19387c6e7bc4a8a90fe2d015fe80"
16SRC_URI[sha256sum] = "e1298022472da5589b7f2be1d5ee3c1b66ec3d96dfbad03dc642afd009da5342"
17
18EXTRA_OECONF = "--disable-device-mapper"
19
20inherit autotools pkgconfig gettext texinfo ptest
21
22PACKAGECONFIG ?= "readline"
23PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
24
25BBCLASSEXTEND = "native nativesdk"
26
27do_compile_ptest() {
28 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize print-flags
29}
30
31do_install_ptest() {
32 t=${D}${PTEST_PATH}
33 mkdir $t/build-aux
34 cp ${S}/build-aux/test-driver $t/build-aux/
35 cp -r ${S}/tests $t
36 cp ${B}/tests/Makefile $t/tests/
37 sed -i "s|^VERSION.*|VERSION = ${PV}|g" $t/tests/Makefile
38 sed -i "s|^srcdir =.*|srcdir = \.|g" $t/tests/Makefile
39 sed -i "s|^abs_srcdir =.*|abs_srcdir = \.|g" $t/tests/Makefile
40 sed -i "s|^abs_top_srcdir =.*|abs_top_srcdir = \.\.|g" $t/tests/Makefile
41 sed -i "s|^Makefile:.*|Makefile:|g" $t/tests/Makefile
42 sed -i "/^BUILDINFO.*$/d" $t/tests/Makefile
43 for i in print-align print-max print-flags dup-clobber duplicate fs-resize; \
44 do cp ${B}/tests/.libs/$i $t/tests/; \
45 done
46 sed -e 's| ../parted||' -i $t/tests/*.sh
47}
48
49RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python3 make gawk e2fsprogs-mke2fs python3-core"
50RRECOMMENDS_${PN}-ptest = "kernel-module-scsi-debug"
51RDEPENDS_${PN}-ptest_append_libc-glibc = "\
52 glibc-utils \
53 locale-base-en-us \
54 "
55
56inherit update-alternatives
57
58ALTERNATIVE_PRIORITY = "100"
59ALTERNATIVE_${PN} = "partprobe"
60ALTERNATIVE_LINK_NAME[partprobe] = "${sbindir}/partprobe"