summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/parted/parted_3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/parted/parted_3.2.bb')
-rw-r--r--meta/recipes-extended/parted/parted_3.2.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/parted/parted_3.2.bb b/meta/recipes-extended/parted/parted_3.2.bb
new file mode 100644
index 0000000000..655a825703
--- /dev/null
+++ b/meta/recipes-extended/parted/parted_3.2.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Disk partition editing/resizing utility"
2HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
5SECTION = "console/tools"
6DEPENDS = "ncurses readline util-linux"
7PR = "r1"
8
9SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
10 file://no_check.patch \
11 file://syscalls.patch \
12 file://fix-doc-mandir.patch \
13 file://fix-compile-failure-while-dis.patch \
14 file://run-ptest \
15 file://Makefile \
16"
17
18SRC_URI[md5sum] = "0247b6a7b314f8edeb618159fa95f9cb"
19SRC_URI[sha256sum] = "858b589c22297cacdf437f3baff6f04b333087521ab274f7ab677cb8c6bb78e4"
20
21EXTRA_OECONF = "--disable-device-mapper"
22
23inherit autotools pkgconfig gettext texinfo ptest
24
25BBCLASSEXTEND = "native"
26
27do_compile_ptest() {
28 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize
29}
30
31do_install_ptest() {
32 t=${D}${PTEST_PATH}
33 mkdir $t/build-aux
34 cp ${S}/build-aux/test-driver $t/build-aux/
35 cp -r ${S}/tests $t
36 cp ${WORKDIR}/Makefile $t/tests/
37 for i in print-align print-max dup-clobber duplicate fs-resize; \
38 do cp ${B}/tests/.libs/$i $t/tests/; \
39 done
40 sed -e 's| ../parted||' -i $t/tests/*.sh
41}
42
43RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup"