summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/parted/parted_3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/parted/parted_3.1.bb')
-rw-r--r--meta/recipes-extended/parted/parted_3.1.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-extended/parted/parted_3.1.bb b/meta/recipes-extended/parted/parted_3.1.bb
new file mode 100644
index 0000000000..3f36f9f79e
--- /dev/null
+++ b/meta/recipes-extended/parted/parted_3.1.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Disk partition editing/resizing utility"
2HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
3LICENSE = "GPLv3+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2f31b266d3440dd7ee50f92cf67d8e6c"
5SECTION = "console/tools"
6DEPENDS = "ncurses readline util-linux"
7PR = "r1"
8
9SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.xz \
10 file://no_check.patch \
11 file://syscalls.patch \
12 file://fix-git-version-gen.patch \
13 file://fix-doc-mandir.patch \
14 file://fix-dvh-overflows.patch \
15 file://fix-deprecated-readline.patch \
16 file://run-ptest \
17 file://Makefile \
18"
19
20SRC_URI[md5sum] = "5d89d64d94bcfefa9ce8f59f4b81bdcb"
21SRC_URI[sha256sum] = "5e9cc1f91eaf016e5033d85b9b893fd6d3ffaca532a48de1082df9b94225ca15"
22
23EXTRA_OECONF = "--disable-device-mapper"
24
25inherit autotools pkgconfig gettext texinfo ptest
26
27BBCLASSEXTEND = "native"
28
29do_compile_ptest() {
30 oe_runmake -C tests print-align print-max dup-clobber duplicate fs-resize
31}
32
33do_install_ptest() {
34 t=${D}${PTEST_PATH}
35 mkdir $t/build-aux
36 cp ${S}/build-aux/test-driver $t/build-aux/
37 cp -r ${S}/tests $t
38 cp ${WORKDIR}/Makefile $t/tests/
39 for i in print-align print-max dup-clobber duplicate fs-resize; \
40 do cp ${B}/tests/.libs/$i $t/tests/; \
41 done
42 sed -e 's| ../parted||' -i $t/tests/*.sh
43}
44
45RDEPENDS_${PN}-ptest = "bash coreutils perl util-linux-losetup python"