summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam/libpam_1.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/pam/libpam_1.5.1.bb')
-rw-r--r--meta/recipes-extended/pam/libpam_1.5.1.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.5.1.bb b/meta/recipes-extended/pam/libpam_1.5.1.bb
index d6612bb936..f225487688 100644
--- a/meta/recipes-extended/pam/libpam_1.5.1.bb
+++ b/meta/recipes-extended/pam/libpam_1.5.1.bb
@@ -23,6 +23,7 @@ SRC_URI = "https://github.com/linux-pam/linux-pam/releases/download/v${PV}/Linux
23 file://libpam-xtests.patch \ 23 file://libpam-xtests.patch \
24 file://0001-modules-pam_namespace-Makefile.am-correctly-install-.patch \ 24 file://0001-modules-pam_namespace-Makefile.am-correctly-install-.patch \
25 file://0001-Makefile.am-support-usrmage.patch \ 25 file://0001-Makefile.am-support-usrmage.patch \
26 file://run-ptest \
26 " 27 "
27 28
28SRC_URI[sha256sum] = "201d40730b1135b1b3cdea09f2c28ac634d73181ccd0172ceddee3649c5792fc" 29SRC_URI[sha256sum] = "201d40730b1135b1b3cdea09f2c28ac634d73181ccd0172ceddee3649c5792fc"
@@ -40,7 +41,7 @@ CFLAGS_append = " -fPIC "
40 41
41S = "${WORKDIR}/Linux-PAM-${PV}" 42S = "${WORKDIR}/Linux-PAM-${PV}"
42 43
43inherit autotools gettext pkgconfig systemd 44inherit autotools gettext pkgconfig systemd ptest
44 45
45PACKAGECONFIG ??= "" 46PACKAGECONFIG ??= ""
46PACKAGECONFIG[audit] = "--enable-audit,--disable-audit,audit," 47PACKAGECONFIG[audit] = "--enable-audit,--disable-audit,audit,"
@@ -112,6 +113,13 @@ python populate_packages_prepend () {
112 do_split_packages(d, pam_filterdir, r'^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='') 113 do_split_packages(d, pam_filterdir, r'^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='')
113} 114}
114 115
116do_compile_ptest() {
117 cd tests
118 sed -i -e 's/$(MAKE) $(AM_MAKEFLAGS) check-TESTS//' Makefile
119 oe_runmake check-am
120 cd -
121}
122
115do_install() { 123do_install() {
116 autotools_do_install 124 autotools_do_install
117 125
@@ -131,6 +139,13 @@ do_install() {
131 fi 139 fi
132} 140}
133 141
142do_install_ptest() {
143 if [ ${PTEST_ENABLED} = "1" ]; then
144 mkdir -p ${D}${PTEST_PATH}/tests
145 install -m 0755 ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests
146 fi
147}
148
134inherit features_check 149inherit features_check
135REQUIRED_DISTRO_FEATURES = "pam" 150REQUIRED_DISTRO_FEATURES = "pam"
136 151