summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam/libpam_1.1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/pam/libpam_1.1.5.bb')
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.5.bb94
1 files changed, 94 insertions, 0 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.5.bb b/meta/recipes-extended/pam/libpam_1.1.5.bb
new file mode 100644
index 0000000000..1ab3a99dc2
--- /dev/null
+++ b/meta/recipes-extended/pam/libpam_1.1.5.bb
@@ -0,0 +1,94 @@
1SUMMARY = "Linux-PAM (Pluggable Authentication Modules)"
2DESCRIPTION = "Linux-PAM (Pluggable Authentication Modules for Linux), a flexible mechanism for authenticating users"
3HOMEPAGE = "https://fedorahosted.org/linux-pam/"
4BUGTRACKER = "https://fedorahosted.org/linux-pam/newticket"
5SECTION = "base"
6# PAM is dual licensed under GPL and BSD.
7# /etc/pam.d comes from Debian libpam-runtime in 2009-11 (at that time
8# libpam-runtime-1.0.1 is GPLv2+), by openembedded
9LICENSE = "GPLv2+ | BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ca0395de9a86191a078b8b79302e3083"
11
12PR = "r0"
13
14SRC_URI = "https://fedorahosted.org/releases/l/i/linux-pam/Linux-PAM-${PV}.tar.bz2 \
15 file://99_pam \
16 file://pam.d/* \
17 file://libpam-xtests.patch"
18
19SRC_URI_append_libc-uclibc = " file://pam-no-innetgr.patch"
20
21SRC_URI[md5sum] = "927ee5585bdec5256c75117e9348aa47"
22SRC_URI[sha256sum] = "65def4df04254dc4c5156859d36c34ad6d7afbcf3adbf2780530ebc4dbf2a116"
23
24DEPENDS = "bison flex flex-native cracklib"
25
26EXTRA_OECONF = "--with-db-uniquename=_pam \
27 --includedir=${includedir}/security \
28 --libdir=${base_libdir} \
29 --disable-regenerate-docu"
30
31CFLAGS_append = " -fPIC "
32
33S = "${WORKDIR}/Linux-PAM-${PV}"
34
35inherit autotools gettext
36
37PACKAGES += "${PN}-runtime ${PN}-xtests"
38FILES_${PN} = "${base_libdir}/lib*${SOLIBS}"
39FILES_${PN}-dbg += "${base_libdir}/security/.debug \
40 ${base_libdir}/security/pam_filter/.debug \
41 ${datadir}/Linux-PAM/xtests/.debug"
42
43FILES_${PN}-dev += "${base_libdir}/security/*.la ${base_libdir}/*.la ${base_libdir}/lib*${SOLIBSDEV}"
44FILES_${PN}-runtime = "${sysconfdir}"
45FILES_${PN}-xtests = "${datadir}/Linux-PAM/xtests"
46
47PACKAGES_DYNAMIC += " pam-plugin-*"
48
49RDEPENDS_${PN}-runtime = "libpam pam-plugin-deny pam-plugin-permit pam-plugin-warn pam-plugin-unix"
50RDEPENDS_${PN}-xtests = "libpam pam-plugin-access pam-plugin-debug pam-plugin-cracklib pam-plugin-pwhistory pam-plugin-succeed-if pam-plugin-time coreutils"
51RRECOMMENDS_${PN} = "libpam-runtime"
52
53python populate_packages_prepend () {
54 import os.path
55
56 def pam_plugin_append_file(pn, dir, file):
57 nf = os.path.join(dir, file)
58 of = d.getVar('FILES_' + pn, True)
59 if of:
60 nf = of + " " + nf
61 d.setVar('FILES_' + pn, nf)
62
63 dvar = bb.data.expand('${WORKDIR}/package', d, True)
64 pam_libdir = bb.data.expand('${base_libdir}/security', d)
65 pam_sbindir = bb.data.expand('${sbindir}', d)
66 pam_filterdir = bb.data.expand('${base_libdir}/security/pam_filter', d)
67
68 do_split_packages(d, pam_libdir, '^pam(.*)\.so$', 'pam-plugin%s', 'PAM plugin for %s', extra_depends='')
69 pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_chkpwd')
70 pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_update')
71 pam_plugin_append_file('pam-plugin-tally', pam_sbindir, 'pam_tally')
72 pam_plugin_append_file('pam-plugin-tally2', pam_sbindir, 'pam_tally2')
73 pam_plugin_append_file('pam-plugin-timestamp', pam_sbindir, 'pam_timestamp_check')
74 pam_plugin_append_file('pam-plugin-mkhomedir', pam_sbindir, 'mkhomedir_helper')
75 do_split_packages(d, pam_filterdir, '^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='')
76}
77
78do_install() {
79 autotools_do_install
80
81 # don't install /var/run when populating rootfs. Do it through volatile
82 rm -rf ${D}/var
83 install -d ${D}${sysconfdir}/default/volatiles
84 install -m 0644 ${WORKDIR}/99_pam ${D}/etc/default/volatiles
85
86 install -d ${D}${sysconfdir}/pam.d/
87 install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/
88}
89
90pkg_postinst_pam-plugin-unix () {
91 # below is necessary to allow unix_chkpwd get user info from shadow file
92 # on lsb images
93 chmod 4755 ${sbindir}/unix_chkpwd
94}