summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam/libpam_1.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/pam/libpam_1.1.3.bb')
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.3.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.3.bb b/meta/recipes-extended/pam/libpam_1.1.3.bb
new file mode 100644
index 0000000000..7a8b29a93c
--- /dev/null
+++ b/meta/recipes-extended/pam/libpam_1.1.3.bb
@@ -0,0 +1,79 @@
1SUMMARY = "Linux-PAM (Pluggable Authentication Modules)"
2DESCRIPTION = "Linux-PAM (Pluggable Authentication Modules for Linux), Basically, it is a flexible mechanism for authenticating users"
3HOMEPAGE = "http://www.kernel.org/pub/linux/libs/pam/"
4BUGTRACKER = "http://sourceforge.net/projects/pam/support"
5SECTION = "base"
6# PAM is dual licensed under GPL and BSD.
7# /etc/pam.d comes from Debian libpam-runtime in 2009-11 (at that time
8# libpam-runtime-1.0.1 is GPLv2+), by openembedded
9LICENSE = "GPLv2+ | BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ca0395de9a86191a078b8b79302e3083"
11
12PR = "r0"
13
14DEPENDS = "bison flex"
15RDEPENDS_${PN}-runtime = "libpam pam-plugin-deny pam-plugin-permit pam-plugin-warn pam-plugin-unix"
16RRECOMMENDS_${PN} = "libpam-runtime"
17
18SRC_URI = "http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-${PV}.tar.bz2 \
19 file://99_pam \
20 file://pam.d/*"
21
22SRC_URI[md5sum] = "6db7fcb5db6253350e3a4648ceac40e7"
23SRC_URI[sha256sum] = "17b268789b935a76e736a1150210dd12f156972973e79347668f828d43632652"
24
25EXTRA_OECONF = "--with-db-uniquename=_pam \
26 --includedir=${includedir}/security \
27 --libdir=${base_libdir} \
28 --disable-regenerate-docu"
29CFLAGS_append = " -fPIC "
30
31S = "${WORKDIR}/Linux-PAM-${PV}"
32
33inherit autotools gettext
34
35PACKAGES += "${PN}-runtime"
36FILES_${PN} = "${base_libdir}/lib*${SOLIBS}"
37FILES_${PN}-dbg += "${base_libdir}/security/.debug \
38 ${base_libdir}/security/pam_filter/.debug"
39FILES_${PN}-dev += "${base_libdir}/security/*.la ${base_libdir}/*.la ${base_libdir}/lib*${SOLIBSDEV}"
40FILES_${PN}-runtime = "${sysconfdir}"
41
42PACKAGES_DYNAMIC += " pam-plugin-*"
43
44python populate_packages_prepend () {
45 import os.path
46
47 def pam_plugin_append_file(pn, dir, file):
48 nf = os.path.join(dir, file)
49 of = bb.data.getVar('FILES_' + pn, d, True)
50 if of:
51 nf = of + " " + nf
52 bb.data.setVar('FILES_' + pn, nf, d)
53
54 dvar = bb.data.expand('${WORKDIR}/package', d, True)
55 pam_libdir = bb.data.expand('${base_libdir}/security', d)
56 pam_sbindir = bb.data.expand('${sbindir}', d)
57 pam_filterdir = bb.data.expand('${base_libdir}/security/pam_filter', d)
58
59 do_split_packages(d, pam_libdir, '^pam(.*)\.so$', 'pam-plugin%s', 'PAM plugin for %s', extra_depends='')
60 pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_chkpwd')
61 pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_update')
62 pam_plugin_append_file('pam-plugin-tally', pam_sbindir, 'pam_tally')
63 pam_plugin_append_file('pam-plugin-tally2', pam_sbindir, 'pam_tally2')
64 pam_plugin_append_file('pam-plugin-timestamp', pam_sbindir, 'pam_timestamp_check')
65 pam_plugin_append_file('pam-plugin-mkhomedir', pam_sbindir, 'mkhomedir_helper')
66 do_split_packages(d, pam_filterdir, '^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='')
67}
68
69do_install() {
70 autotools_do_install
71
72 # don't install /var/run when populating rootfs. Do it through volatile
73 rm -rf ${D}/var
74 install -d ${D}${sysconfdir}/default/volatiles
75 install -m 0644 ${WORKDIR}/99_pam ${D}/etc/default/volatiles
76
77 install -d ${D}${sysconfdir}/pam.d/
78 install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/
79}