summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/pam/libpam_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/pam/libpam_1.1.1.bb')
-rw-r--r--meta/recipes-extended/pam/libpam_1.1.1.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.1.1.bb b/meta/recipes-extended/pam/libpam_1.1.1.bb
new file mode 100644
index 0000000000..536a0f5ce9
--- /dev/null
+++ b/meta/recipes-extended/pam/libpam_1.1.1.bb
@@ -0,0 +1,73 @@
1DESCRIPTION = "Linux-PAM (Pluggable Authentication Modules for Linux), Basically, it is a flexible mechanism for authenticating users"
2HOMEPAGE = "http://www.kernel.org/pub/linux/libs/pam/"
3BUGTRACKER = "http://sourceforge.net/projects/pam/support"
4# PAM allows dual licensed under GPL and BSD.
5# /etc/pam.d comes from Debian libpam-runtime in 2009-11 (at that time
6# libpam-runtime-1.0.1 is GPLv2+), by openembedded
7LICENSE = "GPLv2+ | BSD"
8PR = "r1"
9
10DEPENDS = "bison flex"
11RDEPENDS_${PN}-runtime = "libpam pam-plugin-deny pam-plugin-permit pam-plugin-warn pam-plugin-unix"
12RRECOMMENDS_${PN} = "libpam-runtime"
13
14SRC_URI = "http://www.kernel.org/pub/linux/libs/pam/library/Linux-PAM-${PV}.tar.bz2 \
15 file://disable_crossbinary.patch \
16 file://99_pam \
17 file://pam.d/*"
18
19EXTRA_OECONF = "--with-db-uniquename=_pam \
20 --includedir=${includedir}/security \
21 --libdir=${base_libdir} \
22 --disable-regenerate-docu"
23CFLAGS_append = " -fPIC "
24
25S = "${WORKDIR}/Linux-PAM-${PV}"
26
27inherit autotools gettext
28
29PACKAGES += "${PN}-runtime"
30FILES_${PN} = "${base_libdir}/lib*${SOLIBS}"
31FILES_${PN}-dbg += "${base_libdir}/security/.debug \
32 ${base_libdir}/security/pam_filter/.debug"
33FILES_${PN}-dev += "${base_libdir}/security/*.la ${base_libdir}/*.la ${base_libdir}/lib*${SOLIBSDEV}"
34FILES_${PN}-runtime = "${sysconfdir}"
35
36PACKAGES_DYNAMIC += " pam-plugin-*"
37
38python populate_packages_prepend () {
39 import os.path
40
41 def pam_plugin_append_file(pn, dir, file):
42 nf = os.path.join(dir, file)
43 of = bb.data.getVar('FILES_' + pn, d, True)
44 if of:
45 nf = of + " " + nf
46 bb.data.setVar('FILES_' + pn, nf, d)
47
48 dvar = bb.data.expand('${WORKDIR}/package', d, True)
49 pam_libdir = bb.data.expand('${base_libdir}/security', d)
50 pam_sbindir = bb.data.expand('${sbindir}', d)
51 pam_filterdir = bb.data.expand('${base_libdir}/security/pam_filter', d)
52
53 do_split_packages(d, pam_libdir, '^pam(.*)\.so$', 'pam-plugin%s', 'PAM plugin for %s', extra_depends='')
54 pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_chkpwd')
55 pam_plugin_append_file('pam-plugin-unix', pam_sbindir, 'unix_update')
56 pam_plugin_append_file('pam-plugin-tally', pam_sbindir, 'pam_tally')
57 pam_plugin_append_file('pam-plugin-tally2', pam_sbindir, 'pam_tally2')
58 pam_plugin_append_file('pam-plugin-timestamp', pam_sbindir, 'pam_timestamp_check')
59 pam_plugin_append_file('pam-plugin-mkhomedir', pam_sbindir, 'mkhomedir_helper')
60 do_split_packages(d, pam_filterdir, '^(.*)$', 'pam-filter-%s', 'PAM filter for %s', extra_depends='')
61}
62
63do_install() {
64 autotools_do_install
65
66 # don't install /var/run when populating rootfs. Do it through volatile
67 rm -rf ${D}/var
68 install -d ${D}${sysconfdir}/default/volatiles
69 install -m 0644 ${WORKDIR}/99_pam ${D}/etc/default/volatiles
70
71 install -d ${D}${sysconfdir}/pam.d/
72 install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/
73}