summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb266
1 files changed, 266 insertions, 0 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
new file mode 100644
index 0000000000..e0f32e0a1d
--- /dev/null
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
@@ -0,0 +1,266 @@
1#
2# Copyright (C) 2010 Intel Corporation
3#
4
5SUMMARY = "Linux Standard Base (LSB)"
6DESCRIPTION = "Packages required to satisfy the Linux Standard Base (LSB) specification"
7PR = "r10"
8LICENSE = "MIT"
9
10inherit packagegroup
11
12PACKAGES = "\
13 packagegroup-core-lsb \
14 packagegroup-core-sys-extended \
15 packagegroup-core-db \
16 packagegroup-core-perl \
17 packagegroup-core-python \
18 packagegroup-core-tcl \
19 packagegroup-core-lsb-misc \
20 packagegroup-core-lsb-core \
21 packagegroup-core-lsb-perl \
22 packagegroup-core-lsb-python \
23 packagegroup-core-lsb-desktop \
24 packagegroup-core-lsb-runtime-add \
25 "
26
27
28RDEPENDS_packagegroup-core-lsb = "\
29 packagegroup-core-sys-extended \
30 packagegroup-core-db \
31 packagegroup-core-perl \
32 packagegroup-core-python \
33 packagegroup-core-tcl \
34 packagegroup-core-lsb-misc \
35 packagegroup-core-lsb-core \
36 packagegroup-core-lsb-perl \
37 packagegroup-core-lsb-python \
38 packagegroup-core-lsb-desktop \
39 packagegroup-core-lsb-runtime-add \
40 "
41
42
43RDEPENDS_packagegroup-core-sys-extended = "\
44 curl \
45 dhcp-client \
46 gamin \
47 hdparm \
48 libaio \
49 lrzsz \
50 lzo \
51 mc \
52 mc-fish \
53 mc-helpers \
54 mc-helpers-perl \
55 mc-helpers-python \
56 mdadm \
57 minicom \
58 neon \
59 parted \
60 ${PTH} \
61 quota \
62 screen \
63 setserial \
64 sysstat \
65 udev-extraconf \
66 unzip \
67 watchdog \
68 wget \
69 which \
70 xinetd \
71 zip \
72 "
73
74RDEPENDS_packagegroup-core-db = "\
75 db \
76 sqlite3 \
77 "
78
79RDEPENDS_packagegroup-core-perl = "\
80 gdbm \
81 perl \
82 zlib \
83 "
84
85
86RDEPENDS_packagegroup-core-python = "\
87 expat \
88 gdbm \
89 gmp \
90 ncurses \
91 openssl \
92 python \
93 readline \
94 zip \
95 "
96
97RDEPENDS_packagegroup-core-tcl = "\
98 tcl \
99 "
100
101# Miscellaneous packages required by LSB (or LSB tests)
102RDEPENDS_packagegroup-core-lsb-misc = "\
103 chkconfig \
104 gettext \
105 gettext-runtime \
106 groff \
107 lsbinitscripts \
108 lsbtest \
109 lsof \
110 strace \
111 libusb1 \
112 usbutils \
113 rpm \
114 "
115
116SUMMARY_packagegroup-core-lsb-core = "LSB Core"
117DESCRIPTION_packagegroup-core-lsb-core = "Packages required to support commands/libraries \
118 specified in the LSB Core specification"
119RDEPENDS_packagegroup-core-lsb-core = "\
120 at \
121 bash \
122 bc \
123 binutils \
124 binutils-symlinks \
125 coreutils \
126 cpio \
127 cronie \
128 cups \
129 diffutils \
130 ed \
131 glibc-utils \
132 elfutils \
133 file \
134 findutils \
135 fontconfig-utils \
136 foomatic-filters \
137 gawk \
138 ghostscript \
139 grep \
140 gzip \
141 localedef \
142 lsb \
143 m4 \
144 mailx \
145 make \
146 man \
147 man-pages \
148 mktemp \
149 msmtp \
150 patch \
151 pax \
152 procps \
153 psmisc \
154 sed \
155 shadow \
156 tar \
157 time \
158 util-linux \
159 xdg-utils \
160 \
161 glibc \
162 libgcc \
163 libpam \
164 libxml2 \
165 ncurses \
166 zlib \
167 nspr \
168 libpng12 \
169 nss \
170"
171
172SUMMARY_packagegroup-core-lsb-perl = "LSB Runtime Languages (Perl)"
173DESCRIPTION_packagegroup-core-lsb-perl = "Packages required to support libraries \
174 specified in the LSB Runtime languages specification (Perl parts)"
175RDEPENDS_packagegroup-core-lsb-perl = "\
176 perl \
177 perl-modules \
178 perl-misc \
179 perl-pod \
180 perl-dev \
181 perl-doc \
182"
183
184SUMMARY_packagegroup-core-lsb-python = "LSB Runtime Languages (Python)"
185DESCRIPTION_packagegroup-core-lsb-python = "Packages required to support libraries \
186 specified in the LSB Runtime languages specification (Python parts)"
187RDEPENDS_packagegroup-core-lsb-python = "\
188 python \
189 python-modules \
190 python-misc \
191"
192
193def get_libqt3(d):
194 if 'linuxstdbase' in d.getVar('DISTROOVERRIDES') or "":
195 if 'qt3' in d.getVar('BBFILE_COLLECTIONS') or "":
196 return 'libqt-mt3'
197
198 bb.warn('The meta-qt3 layer should be added, this layer provides Qt 3.x' \
199 'libraries. Its intended use is for passing LSB tests as Qt3 is' \
200 'a requirement for LSB.')
201 return ''
202
203QT4PKGS = " \
204 libqtcore4 \
205 libqtgui4 \
206 libqtsql4 \
207 libqtsvg4 \
208 libqtxml4 \
209 libqtnetwork4 \
210 qt4-plugin-sqldriver-sqlite \
211 ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "libqtopengl4", "", d)} \
212 "
213QT4PKGS_mips64 = ""
214QT4PKGS_mips64n32 = ""
215
216SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
217DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
218 specified in the LSB Desktop specification"
219RDEPENDS_packagegroup-core-lsb-desktop = "\
220 libxt \
221 libxxf86vm \
222 libdrm \
223 libglu \
224 libxi \
225 libxtst \
226 libx11-locale \
227 xorg-minimal-fonts \
228 gdk-pixbuf-loader-ico \
229 gdk-pixbuf-loader-bmp \
230 gdk-pixbuf-loader-ani \
231 gdk-pixbuf-xlib \
232 liberation-fonts \
233 gtk+ \
234 atk \
235 libasound \
236 ${QT4PKGS} \
237 ${@get_libqt3(d)} \
238"
239
240RDEPENDS_packagegroup-core-lsb-runtime-add = "\
241 ldd \
242 pam-plugin-wheel \
243 e2fsprogs-mke2fs \
244 mkfontdir \
245 liburi-perl \
246 libxml-parser-perl \
247 libxml-perl \
248 libxml-sax-perl \
249 glibc-localedatas \
250 glibc-gconvs \
251 glibc-charmaps \
252 glibc-binaries \
253 glibc-localedata-posix \
254 glibc-extra-nss \
255 glibc-pcprofile \
256 libclass-isa-perl \
257 libenv-perl \
258 libdumpvalue-perl \
259 libfile-checktree-perl \
260 libi18n-collate-perl \
261 libpod-plainer-perl \
262"
263
264PTH = "pth"
265PTH_libc-uclibc = ""
266