summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/newt/libnewt_0.52.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/newt/libnewt_0.52.14.bb')
-rw-r--r--meta/recipes-extended/newt/libnewt_0.52.14.bb24
1 files changed, 18 insertions, 6 deletions
diff --git a/meta/recipes-extended/newt/libnewt_0.52.14.bb b/meta/recipes-extended/newt/libnewt_0.52.14.bb
index 0208695699..c1ec029c56 100644
--- a/meta/recipes-extended/newt/libnewt_0.52.14.bb
+++ b/meta/recipes-extended/newt/libnewt_0.52.14.bb
@@ -15,28 +15,40 @@ LICENSE = "LGPLv2"
15LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605" 15LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
16 16
17# slang needs to be >= 2.2 17# slang needs to be >= 2.2
18DEPENDS = "slang popt" 18DEPENDS = "slang popt python"
19 19
20PR = "r1" 20PR = "r2"
21 21
22SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \ 22SRC_URI = "https://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \
23 file://remove_slang_include.patch \ 23 file://remove_slang_include.patch \
24 file://fix_SHAREDDIR.patch \ 24 file://fix_SHAREDDIR.patch \
25 file://cross_ar.patch" 25 file://cross_ar.patch \
26 file://fix_python_fpic.patch"
26 27
27SRC_URI[md5sum] = "eb78c6bb658b92ec7198908b5b8d0e37" 28SRC_URI[md5sum] = "eb78c6bb658b92ec7198908b5b8d0e37"
28SRC_URI[sha256sum] = "f70f4f58baa60388ddf2e39249ffb00898fb40f2b2767e42e2ab51fe4b40978e" 29SRC_URI[sha256sum] = "f70f4f58baa60388ddf2e39249ffb00898fb40f2b2767e42e2ab51fe4b40978e"
29 30
30S = "${WORKDIR}/newt-${PV}" 31S = "${WORKDIR}/newt-${PV}"
31 32
32EXTRA_OECONF = "--without-python --without-tcl" 33EXTRA_OECONF = "--without-tcl"
33 34
34inherit autotools 35inherit autotools pythonnative python-dir
35 36
36PACKAGES_prepend = "whiptail " 37EXTRA_OEMAKE = "PYTHONVERS=${PYTHON_DIR}"
38
39export STAGING_INCDIR
40export STAGING_LIBDIR
41
42export BUILD_SYS
43export HOST_SYS
44
45PACKAGES_prepend = "whiptail ${PN}-python "
37 46
38do_configure_prepend() { 47do_configure_prepend() {
39 sh autogen.sh 48 sh autogen.sh
40} 49}
41 50
42FILES_whiptail = "${bindir}/whiptail" 51FILES_whiptail = "${bindir}/whiptail"
52FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/"
53FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
54FILES_${PN}-staticdev = "${libdir}/*.a"