summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/net-tools/net-tools_1.60-23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/net-tools/net-tools_1.60-23.bb')
-rw-r--r--meta/recipes-extended/net-tools/net-tools_1.60-23.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/meta/recipes-extended/net-tools/net-tools_1.60-23.bb b/meta/recipes-extended/net-tools/net-tools_1.60-23.bb
new file mode 100644
index 0000000000..031169c067
--- /dev/null
+++ b/meta/recipes-extended/net-tools/net-tools_1.60-23.bb
@@ -0,0 +1,77 @@
1SUMMARY="A collection of programs that form the base set of the NET-3 networking distribution for the Linux operating system"
2HOMEPAGE = "http://net-tools.berlios.de/"
3BUGTRACKER = "http://bugs.debian.org/net-tools"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
6 file://ifconfig.c;startline=11;endline=15;md5=da4c7bb79a5d0798faa99ef869721f4a"
7PR = "r0"
8
9SRC_URI = "ftp://ftp.debian.org/debian/pool/main/n/net-tools/net-tools_1.60.orig.tar.gz \
10 ftp://ftp.debian.org/debian/pool/main/n/net-tools/${PN}_${PV}.diff.gz;apply=no \
11 file://net-tools-config.h \
12 file://net-tools-config.make"
13
14S = "${WORKDIR}/net-tools-1.60"
15
16inherit gettext
17
18# The Makefile is lame, no parallel build
19PARALLEL_MAKE = ""
20
21# Unlike other Debian packages, net-tools *.diff.gz contains another series of
22# patches maintained by quilt. So manually apply them before applying other local
23# patches. Also remove all temp files before leaving, because do_patch() will pop
24# up all previously applied patches in the start
25nettools_do_patch() {
26 cd ${S}
27 patch -p1 < ${WORKDIR}/${PN}_${PV}.diff
28 QUILT_PATCHES=${S}/debian/patches quilt push -a
29 rm -rf ${S}/patches ${S}/.pc
30}
31
32# We invoke base do_patch at end, to incorporate any local patch
33python do_patch() {
34 bb.build.exec_func('nettools_do_patch', d)
35 bb.build.exec_func('patch_do_patch', d)
36}
37
38do_configure() {
39 # net-tools has its own config mechanism requiring "make config"
40 # we pre-generate desired options and copy to source directory instead
41 cp ${WORKDIR}/net-tools-config.h ${S}/config.h
42 cp ${WORKDIR}/net-tools-config.make ${S}/config.make
43}
44
45do_compile() {
46 # net-tools use COPTS/LOPTS to allow adding custom options
47 export COPTS="$CFLAGS"
48 export LOPTS="$LDFLAGS"
49 unset CFLAGS
50 unset LDFLAGS
51
52 oe_runmake
53}
54
55do_install() {
56 oe_runmake 'BASEDIR=${D}' install
57
58 for app in ${D}/${base_sbindir}/* ${D}/${base_bindir}/*; do
59 mv $app $app.${PN}
60 done
61}
62
63pkg_postinst_${PN} () {
64 for app in arp ifconfig ipmaddr iptunnel mii-tool nameif plipconfig rarp route slattach ; do
65 update-alternatives --install ${base_sbindir}/$app $app $app.${PN} 100
66 done
67
68 for app in dnsdomainname domainname hostname netstat nisdomainname ypdomainname ; do
69 update-alternatives --install ${base_bindir}/$app $app $app.${PN} 100
70 done
71}
72
73pkg_prerm_${PN} () {
74 for app in arp ifconfig ipmaddr iptunnel mii-tool nameif plipconfig rarp route slattach dnsdomainname domainname hostname netstat nisdomainname ypdomainname ; do
75 update-alternatives --remove $app $app.${PN}
76 done
77}