summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mktemp/mktemp_1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/mktemp/mktemp_1.7.bb')
-rw-r--r--meta/recipes-extended/mktemp/mktemp_1.7.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/mktemp/mktemp_1.7.bb b/meta/recipes-extended/mktemp/mktemp_1.7.bb
new file mode 100644
index 0000000000..b53fc11b1e
--- /dev/null
+++ b/meta/recipes-extended/mktemp/mktemp_1.7.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Enables safe temporary file creation from shell scripts"
2HOMEPAGE = "http://www.mktemp.org/"
3BUGTRACKER = "http://www.mktemp.org/bugs"
4SECTION = "console/utils"
5LICENSE = "ISC"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=430680f6322a1eb87199b5e01a82c0d4"
7
8PR = "r3"
9
10SRC_URI = "ftp://ftp.mktemp.org/pub/mktemp/${BPN}-${PV}.tar.gz \
11 file://disable-strip.patch \
12 file://fix-parallel-make.patch \
13 "
14
15SRC_URI[md5sum] = "787bbed9fa2ee8e7645733c0e8e65172"
16SRC_URI[sha256sum] = "8e94b9e1edf866b2609545da65b627996ac5d158fda071e492bddb2f4a482675"
17
18inherit autotools update-alternatives
19
20EXTRA_OECONF = "--with-libc"
21
22do_install_append () {
23 install -d ${D}${base_bindir}
24 mv ${D}${bindir}/mktemp ${D}${base_bindir}/mktemp
25 rmdir ${D}${bindir}
26}
27
28ALTERNATIVE_${PN} = "mktemp"
29ALTERNATIVE_LINK_NAME[mktemp] = "${base_bindir}/mktemp"
30ALTERNATIVE_PRIORITY = "100"