summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mktemp/mktemp_1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/mktemp/mktemp_1.7.bb')
-rw-r--r--meta/recipes-extended/mktemp/mktemp_1.7.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/mktemp/mktemp_1.7.bb b/meta/recipes-extended/mktemp/mktemp_1.7.bb
new file mode 100644
index 0000000000..a34827450c
--- /dev/null
+++ b/meta/recipes-extended/mktemp/mktemp_1.7.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Allow safe temporary file creation from shell scripts."
2HOMEPAGE = "http://www.mktemp.org/"
3BUGTRACKER = "http://www.mktemp.org/bugs"
4SECTION = "console/utils"
5LICENSE = "ISC style"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=430680f6322a1eb87199b5e01a82c0d4"
7
8PR = "r0"
9
10SRC_URI = "ftp://ftp.mktemp.org/pub/mktemp/${P}.tar.gz \
11 file://disable-strip.patch \
12 "
13
14inherit autotools update-alternatives
15
16EXTRA_OECONF = "--with-libc"
17
18do_install_append () {
19 mkdir ${D}${base_bindir}
20 mv ${D}${bindir}/mktemp ${D}${base_bindir}/mktemp.${PN}
21}
22
23ALTERNATIVE_NAME = "mktemp"
24ALTERNATIVE_LINK = "${base_bindir}/mktemp"
25ALTERNATIVE_PATH = "${base_bindir}/mktemp.${PN}"
26ALTERNATIVE_PRIORITY = "100"