summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/minicom/minicom_2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/minicom/minicom_2.7.bb')
-rw-r--r--meta/recipes-extended/minicom/minicom_2.7.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/minicom/minicom_2.7.bb b/meta/recipes-extended/minicom/minicom_2.7.bb
new file mode 100644
index 0000000000..c002bc82d9
--- /dev/null
+++ b/meta/recipes-extended/minicom/minicom_2.7.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Text-based modem control and terminal emulation program"
2DESCRIPTION = "Minicom is a text-based modem control and terminal emulation program for Unix-like operating systems"
3SECTION = "console/network"
4DEPENDS = "ncurses virtual/libiconv"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=420477abc567404debca0a2a1cb6b645 \
7 file://src/minicom.h;beginline=1;endline=12;md5=a58838cb709f0db517f4e42730c49e81"
8
9SRC_URI = "https://alioth.debian.org/frs/download.php/latestfile/3/${BP}.tar.gz \
10 file://allow.to.disable.lockdev.patch \
11 file://0001-fix-minicom-h-v-return-value-is-not-0.patch \
12 "
13
14SRC_URI[md5sum] = "7044ca3e291268c33294f171d426dc2d"
15SRC_URI[sha256sum] = "9ac3a663b82f4f5df64114b4792b9926b536c85f59de0f2d2b321c7626a904f4"
16
17PACKAGECONFIG ??= ""
18PACKAGECONFIG[lockdev] = "--enable-lockdev,--disable-lockdev,lockdev"
19
20inherit autotools gettext pkgconfig
21
22do_install() {
23 for d in doc extras man lib src; do make -C $d DESTDIR=${D} install; done
24}
25