summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mingetty/mingetty_1.08.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/mingetty/mingetty_1.08.bb')
-rw-r--r--meta/recipes-extended/mingetty/mingetty_1.08.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/mingetty/mingetty_1.08.bb b/meta/recipes-extended/mingetty/mingetty_1.08.bb
new file mode 100644
index 0000000000..f1936afd23
--- /dev/null
+++ b/meta/recipes-extended/mingetty/mingetty_1.08.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Compact getty terminal handler for virtual consoles only"
2SECTION = "console/utils"
3HOMEPAGE = "http://sourceforge.net/projects/mingetty/"
4LICENSE = "GPLv2"
5PR = "r3"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e"
8SRC_URI = "http://cdnetworks-kr-1.dl.sourceforge.net/project/mingetty/mingetty/${PV}/mingetty-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "2a75ad6487ff271424ffc00a64420990"
11SRC_URI[sha256sum] = "0f55c90ba4faa913d91ef99cbf5cb2eb4dbe2780314c3bb17953f849c8cddd17"
12
13# substitute our CFLAGS for "-O2 -Wall -W -pipe"
14#
15EXTRA_OEMAKE = "CC='${CC}' \
16 CFLAGS='${CFLAGS} -D_GNU_SOURCE'"
17
18do_install(){
19 install -d ${D}${mandir}/man8 ${D}/${base_sbindir}
20 oe_runmake install DESTDIR=${D}
21}
22
23inherit update-alternatives
24
25ALTERNATIVE_${PN} = "getty"
26ALTERNATIVE_LINK_NAME[getty] = "${base_sbindir}/getty"
27ALTERNATIVE_TARGET[getty] = "${base_sbindir}/mingetty"
28ALTERNATIVE_PRIORITY = "10"