summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.3.1.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.3.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.3.1.bb b/meta/recipes-extended/mdadm/mdadm_3.3.1.bb
new file mode 100644
index 0000000000..3c43e0d867
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.3.1.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Tool for managing software RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3
4# Some files are GPLv2+ while others are GPLv2.
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
8 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
9
10
11SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
12 file://mdadm-3.2.2_fix_for_x32.patch \
13 file://gcc-4.9.patch \
14 "
15
16SRC_URI[md5sum] = "4227d48de62dfb217c92fa0c54171bbe"
17SRC_URI[sha256sum] = "d8c74112cfd77bdc1dbc1291fe8d9243c76d91bfa276fcb95f2a75ca7717ab02"
18
19CFLAGS += "-fno-strict-aliasing"
20
21inherit autotools-brokensep
22
23# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
24do_configure_prepend () {
25 sed -i -e '/.*ansidecl.h.*/d' ${S}/sha1.h
26}
27
28EXTRA_OEMAKE = "CHECK_RUN_DIR=0"
29# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
30# prevents 64-bit userland from seeing this definition, instead defaulting
31# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
32# int-ll64.h included
33EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
34EXTRA_OEMAKE_append_mips64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
35EXTRA_OEMAKE_append_mips64n32 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
36
37do_compile() {
38 oe_runmake
39}
40
41do_install() {
42 export STRIP=""
43 autotools_do_install
44}
45
46FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules"