summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.1.4.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.1.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.1.4.bb b/meta/recipes-extended/mdadm/mdadm_3.1.4.bb
new file mode 100644
index 0000000000..b28e96b759
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.1.4.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = " A tool for managing Soft RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3BUGTRACKER = "n/a"
4
5#A few files are GPLv2+ while most files are GPLv2.
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
8 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
9 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
10
11PR = "r0"
12
13SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/raid/mdadm/${PN}-${PV}.tar.bz2"
14
15CFLAGS += "-fno-strict-aliasing"
16
17inherit autotools
18
19do_compile() {
20 export CROSS_COMPILE="${TARGET_PREFIX}"
21 oe_runmake
22}
23
24do_install() {
25 export STRIP=""
26 autotools_do_install
27}
28