summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man/man_1.6g.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/man/man_1.6g.bb')
-rw-r--r--meta/recipes-extended/man/man_1.6g.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-extended/man/man_1.6g.bb b/meta/recipes-extended/man/man_1.6g.bb
new file mode 100644
index 0000000000..03fffd6015
--- /dev/null
+++ b/meta/recipes-extended/man/man_1.6g.bb
@@ -0,0 +1,79 @@
1SUMMARY = "Online documentation tools"
2DESCRIPTION = "A set of documentation tools: man, apropos and whatis"
3SECTION = "console/utils"
4HOMEPAGE = "http://primates.ximian.com/~flucifredi/man"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
7
8PR = "r1"
9
10DEPENDS = "groff less"
11
12def compress_pkg(d):
13 if "compress_doc" in (d.getVar("INHERIT", True) or "").split():
14 compress = d.getVar("DOC_COMPRESS", True)
15 if compress == "gz":
16 return "gzip"
17 elif compress == "bz2":
18 return "bzip2"
19 elif compress == "xz":
20 return "xz"
21 return ""
22
23RDEPENDS_${PN} += "${@compress_pkg(d)}"
24
25SRC_URI = "http://primates.ximian.com/~flucifredi/${BPN}/${BPN}-${PV}.tar.gz \
26 file://man-1.5k-confpath.patch;striplevel=0 \
27 file://man-1.5h1-make.patch \
28 file://man-1.5k-nonascii.patch \
29 file://man-1.6e-security.patch \
30 file://man-1.6e-mandirs.patch \
31 file://man-1.5m2-bug11621.patch \
32 file://man-1.5k-sofix.patch \
33 file://man-1.5m2-buildroot.patch \
34 file://man-1.6e-ro_usr.patch \
35 file://man-1.5i2-newline.patch;striplevel=0 \
36 file://man-1.5j-utf8.patch \
37 file://man-1.5i2-overflow.patch \
38 file://man-1.5j-nocache.patch \
39 file://man-1.5i2-initial.patch \
40 file://man-1.5h1-gencat.patch;striplevel=0 \
41 file://man-1.5g-nonrootbuild.patch \
42 file://man-1.5m2-tv_fhs.patch;striplevel=0 \
43 file://man-1.5j-i18n.patch \
44 file://man-1.6e-whatis2.patch \
45 file://man-1.6e-use_i18n_vars_in_a_std_way.patch \
46 file://man-1.5m2-no-color-for-printing.patch \
47 file://man-1.5m2-sigpipe.patch \
48 file://man-1.6e-i18n_whatis.patch \
49 file://man-1.6e-new_sections.patch \
50 file://man.1.gz;unpack=false \
51 file://man.7.gz;unpack=false \
52 file://man.conf \
53 file://manpath.5.gz;unpack=false"
54
55SRC_URI[md5sum] = "ba154d5796928b841c9c69f0ae376660"
56SRC_URI[sha256sum] = "ccdcb8c3f4e0080923d7e818f0e4a202db26c46415eaef361387c20995b8959f"
57
58do_configure () {
59 ${S}/configure -default -confdir /etc +sgid +fhs +lang all
60}
61
62
63fakeroot do_install() {
64 oe_runmake install DESTDIR=${D}
65}
66
67do_install_append(){
68 mkdir -p ${D}${sysconfdir}
69 mkdir -p ${D}${datadir}/man/man5
70 mkdir -p ${D}${datadir}/man/man7
71 cp ${WORKDIR}/man.conf ${D}${sysconfdir}/man.config
72 cp ${WORKDIR}/man.1.gz ${D}${datadir}/man/man1/
73 cp ${WORKDIR}/man.7.gz ${D}${datadir}/man/man7/
74 cp ${WORKDIR}/manpath.5.gz ${D}${datadir}/man/man5/
75}
76
77
78RDEPENDS_${PN} = "less groff"
79FILES_${PN} += "${datadir}/locale ${sysconfdir}/man.config"